Unreal 4 not using my second video card


I have 2 video cards the 1080ti and the GTX780, when I’m using UE4 only the GTX780 is being used. I read that UE4 should pick up the better card automatically but I guess it doesn’t. Could anyone help me?

I am on Win10, one monitor plugged in to GTX780, using latest UE4 version.

Thank you.

Hey there, are your nVidia settings set to Maximize 3D Performance? I’d also try hooking up the monitor to the 1080 to see if it changes the card being used by UE.

Thanks for your suggestions I will try the monitor thing tomorrow but regarding the “Maximize 3D Performance” is that in nVidia Control Panel? If so maybe there is a tutorial on what setting to use there?

Yes, that’s in the nVidia Control Panel and the first thing you wanna check - make sure the editor is not running :slight_smile:

Thanks, but it seems I don’t have that option.

Do things change when you hook up to the 1080 instead? If not then it might be a separate issue with the hardware/SLI itself, which unfortunately I can’t help you with as I don’t have that specific card combo.

Yeah no changes if it change to 1080ti unfortunately. Btw my cards are not SLI connected, is that an issue?

I’d suppose wiring them for SLI would be a prequisite for UE to be able to switch between them without conflicting with Windows. If you don’t want to SLI have your Windows/BIOS run the 1080 as the primary.

thanks for all your help I’ll try the sli bridge, will see how that goes. thanks again.

No problem :slight_smile: