Unreal 4 Launcher for Mac OSX 10.8.5 crashes at startup after update

That’s odd. It should tell you that the minimum version of OS X you can run it on is 10.9.2 and quit. Not sure why it doesn’t do that, but the engine really requires 10.9.2, so I’m afraid you will have to upgrade your system to use it.

Just got an update for Unreal 4 Engine launcher and now when starting up, it immediately crashes. Using Mac OSX 10.8.5.

That is indeed odd, I have been using Unreal for the past month or so on OSX 10.8.5 with no problems up until it just tried to update the launcher. I actually just reinstalled the launcher and opened the Editor in offline mode and it worked just fine. Unfortunately I don’t really have the option of upgrading to Mavericks currently as it is not supported by our IT. Is there any other workaround where I could get updates to the engine without updates to the launcher or anything? Or am I kind of out of luck?

In the new Launcher and UE4 4.1 we switched to 10.9 SDK. We don’t use anything big from Mavericks-only API so far, though, so I guess you could get the code from GitHub, alter a few things and prepare a build that could work in 10.8.5. I could help with that.

May I ask what Mac are you running UE4 on? In particular, I’m curious what graphics card does it have. As far as I remember, only some Nvidia cards had support for some features we need, but even though the editor mostly worked, bugs in drivers causes some crashes when using certain features.

That sounds great. Hopefully our IT will upgrade to Mavericks soon, but we are somewhat behind usually because we have strict security. I am currently running on a Macbook Pro, my graphics card is a NVIDIA GeForce GT 650M. I am assuming that I will need to download UE4 source?