Download

UNREAL 4 - How to stop character´s spring arm to get affected by collision box?

Hi, i created a Flying ship BP and i dont want this ship to land in certain locations (it can get inside, but it canot land), for that i created another BP with a Box Collision and this box has a collision preset “Overlap All Dynamics”, the i use a Beggin- End Overlap for my ship not to be able to land in certain locations wher my box collision is present…BUT, even do it´s working perfect, my ship canot land there and still can fly as usual… My problema is that my character´s spring arms get affected by this box collision, then when my flying ship goes through this locations the Spring Arm probe size is triggered.

How can i avoid that “only” my spring from been affected by Box Collision?

I already tried by selecting in collision presets “Custom” then ignore camera… but it doesnt´work…actually i clicked to ignore averything…but spring arm continues to be affected.

Is ther a better way to create this restricted áreas where you cant do thing but still walk without spring arm or other things in your BP to be affected?

To prevent the ship landing, use a blocking volume.

Not sure about your spring arm but would try to change the Pawn collision to ignore Camera.

To land I would unpossess the ship on BeginOverlap the Box Collision, and possess a new character or vehicle?

But blocking volumen wont allow me to enter to this área and i dont want that… my ship lands when i press H button, then i dont want in some áreas that this happens, i want the ship to be able to fly in these locations BUT not to land, like watter áreas for example…Ship will be able to flight over, but wont be able to land, for this is that i want something to connect a branch condition, that why i used a Box Collision of a BP.

While ship can fly here… spring arm continues to colission.

The unposses proces its already done, it also happnes when i press “H”

Finally solved… to disable my spring arm from reacting to box collision i changed my spring arm “probe channel” to “World Static” now my ship collides without my spring arm to react

Thanks

i made it this way
pic.PNG