Unreal 4.7.1 Errors out when launching on connected ios device (iphone)


I am having some issues with 4.7.1. I do not have any issues with 4.6.1 at all.
When launching to a connected ios device (iphone 6) from the editor, the following error is given;
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 12.513860
PackagingResults:Error: Error Deployment failed! Unknown Error
So I decided to use the iPhonePackager.exe and I went through the following process;

  1. Setup a new cert and keypair, and mobile provision.
  2. Imported the items in step #1.
    At this point, I do not get the normal green checkmark for the provision and cert like I used to get with 4.6.1. Instead I am getting an error regarding UE4Game-Info.plist missing from the 4.7/Engine/Build/IOS directory. This is a fresh install of 4.7.1, so not sure why it’s missing there. Where do I get the UE4Game-Info.plist from?
    I have even setup a brand new project (3rd person) with just the starter content and tried to launch on my device, getting the same error.
    Hope someone can shed some light on this, I am confused?alt text

ok, so I sort of figured it out. Here is how to get around this issue. Even though the editor still throws the unknown error when launching on IOS device, To get around that. Copy Unreal_4\Unreal Engine\4.7\Engine\Intermediate\IOS\UE4game-info.plist to : \Unreal_4\Unreal Engine\4.7\Engine\Build\IOS.
Then make any changes to both plist files in both locations matching the settings in your project. Then go back to the editor and use “File-> Package” option to cook/package your IOS project, then produces the IPA file. Now you can use iPhonePackager to deply the IPA to the device. This approach worked for me. Hopefully this will help anyone else having the same issue.
I hope that at some point, a future update fixes the editor issue so that you can just launch to the device directly via the editor. Thanks

Thanks for the solution. I had the same issue for 4.7.1. I will try your solution.