Unreal 4.26 Running on Android Error

Hi people please HELP with this one,

Basically, I’m getting an error below when trying to test a game on Android :

ERROR: cmd.exe failed with args /c “C:\Users/…\Intermediate\Android\armv7\gradle\rungradle.bat” :app:assembleDebug

I tested the same game 2 days ago on my phone and it worked. Then suddenly, just simply stopped with the above error message.

Im using 4.26 version and please see below the rest of the wonderful error messages Im getting when trying to test my game

FAILURE: Build failed with an exception. LogPlayLevel: What went wrong: LogPlayLevel: Execution failed for task ‘:app:packageDebug’. LogPlayLevel: > A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade LogPlayLevel: > Entry name ‘META-INF/android.arch.lifecycle_extensions.version’ collided LogPlayLevel: Try: LogPlayLevel: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. LogPlayLevel: * Get more help at https://help.gradle.org LogPlayLevel: BUILD FAILED in 8s


1 Like

I, too, am getting the exact same error:

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:packageDebug’.

A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade
Entry name ‘META-INF/android.arch.lifecycle_extensions.version’ collided

I’m running 4.26.1 and also recently installed Android Studio 4.1.2 for Windows 64-bit

I have absolutely no idea what to try to fix this. Google search led to this unanswered forum post. Can anyone shed light on this? I’m attempting to launch to the Quest 2. Thx.

Hei dude,

I’ve figured out how to tackle that beast somehow.

So basically I’ve deleted the content of INTERMEDIATE FOLDER and just tried again and it worked. So just the content of the intermediate folder, not the folder itself.

C:\Users\NAME\Desktop\GAME NAME**\Intermediate**

Hope that helps since this android deployment is a nightmare

Good luck

1 Like

Thanks @triple sunsmith.It is working great

I’ve been struggling with this too, and this worked. Thanks so much for your answer!

thanks man, struggling since 2 days…

I know why it is happening.When you are compiling something and you stopped in middle it will cause corrupted files.So don’t stop your packaging in middle especially when it is compiling.So delete binaries, intermediate and saved and start again