Unreal 4.24 Packaging not working

I tend to want to try to do a package build pretty soon after importing a scene to Unreal via Datasmith. I have had a bad experience where I waited too long into the project and then tried to do a packaging of it for windows only to see it fail. I like to try to find the fail point before waiting until the end.

Anyway, I tried to do a package of a pretty simple one room interior scene and it failed saying something about visual studio and something missing. I did a search and there was another short thread where someone mentioned this is an issue because of missing SDK’s. Nothing seems resolved so I am asking if this is a known issue with 4.24.1 Thanks!

It is a shame no one that has any experience with developing Datasmith or Unreal Studio doesn’t respond to this so I will based upon some other information I saw in another post very recently. Apparently, this busted packaging issue was definitely a bug dealing with Datasmith SDK or something like that. Apparently, 4.24.2 will address this even though there appears to be a workaround.

That kind of crash can be caused by windows folder authority problems, like, when you don’t own the network folder when the whole project folder is sitting there.
Same thing goes with Google drive file stream.

But I can’t say it is the case since I’m relatively newbie one this topic and you are also not providing enough info about crash reports.
Deleting Intermediate folder in the project folder can be a good start though.

It can be literally thousands of reason for the package to crash with only hundred of them being caused by EPIC. So It might be too early to blame someone.


I agree but the build issue was enough that Unreal has supposedly addressed it in 4.24.2. I was not the only person experiencing this.