Download

Unreal 4.17.1 complains XCode 9 beta 6 metal shader compiler is too old

This is new after updating for 4.17 to 4.17.1.

Unreal is now complaining that the XCode metal shader compiler is too old. It says I should use XCode 8 or better.

“Installed XCode Metal Shader compiler is too old, Please update Xcode on this Mac. Falling back to online compiled”

I am on latest XCode 9 beta 6.

Attached is the warning that comes up now in 4.17.1 with XCode 9 beta 6.