Unreal 4.10.4 Crash on play

My game crashes when I play the game in-engine. Here is the report I get:

Hello ,

It seems like the callstack is mentioning something about the SetActorRotation function. Is there an instance of that somewhere in your blueprints/code? If so, could you try removing that to see if it’ll work correctly? Also, what kind of project is this? Is it a new one based off a template or is it something that you’ve created and added quite a bit to?

Hi ,

I also get this in the Unreal Engine when it compiles

. I tried what you suggested, but it didn’t work as you can see in this image

. This project is one that I am following an online course to make, but I have used Unity and C# and trying to learn Unreal and C++ to sharpen my skills. I have only a room created. Would you suggest me to create a new project?

You shouldn’t need to create a new project, as it would be best to find out what is causing this, even if we’re not salvaging much.

Is the project compiling correctly when you have this code commented out? The dylib that the editor is looking for should be generated by the compilation itself. I would suggest trying these steps just to makes sure nothing is being referenced incorrectly:

Close the editor and delete your Binaries and Intermediates folders

Close Visual Studio and right-click your .uproject file and select “Generate Visual Studio Project Files”

Once that process completes, open up the .sln file in Visual Studio

Compile the project

Open the project once that completes and attempt hitting play again.

When generating the XCode project, it should create a workspace file based off what is in your Source folder. Could you post the output from XCode from when it fails to compile? The project won’t do anything until it’s compiled correctly so that is what we need to focus on.

I tried what you suggested and it gave me this error before I could get in the Unreal Editor:

I believe you have to create the Xcode files while you are in the engine so it won’t open to allow me to do that.

Also Xcode gave me some error when I try to compile, but It is all now, it’s like the scripts are all gone.

I only get this now in Xcode without any of my scripts even when I go to my workspace file


Well that definitely doesn’t seem right. I’ll need to look into what could be causing this. In the meantime, can you check to see if those two .xcodeproj files exist on your machine? The UE4 one would be in your engine installation.

I used source control but now Xcode won’t read the changes. I still get those two files, but now Unreal opens and has the files

Have you tried regenerating the project files since you synced to your previous version? That should update the workspace to recognize the newly added files.

Actually I just thought of that too and tried it and it worked! I’ll try and reduplicate the level tonight and if it gives me any problems, I know where to come! Thanks for working with me and trying to problem solve with me!

I’m glad to hear that it’s working! I’ll be ready to help out (out for the weekend though) if you run into any other issues.

This was the error that I got when everything fell apart last time

plus it cannot find the Unreal Engine


now! Had that issue before also!

Are you still getting that compilation error? As for the editor missing from the Dock, this may be due to it pointing to a version of the engine that you don’t have anymore. The easiest way to fix this when it occurs would be to remove that icon from the Dock and find the UE4Editor file inside of Users/Shared/Unreal Engine/4.11/Binaries/Mac and drag/drop it onto the Dock. The version number in that file path will vary with the version you’re using.

Yes I still am getting the compilation error!

Still on 4.10, would you suggest that I upgrade to 4.11?

Would you suggest that I upgrade to 4.11

It should be fine to upgrade if you wish, but in that case I would suggest starting a new project. If this project is already having issues such as this, they’re most likely only going to be worse after migrating the project to a new engine version.

From looking at the screenshot you posted however, it seems like that compilation error might be caused by the AActor “Owner” being declared twice. Could you check your code to ensure that it isn’t? It seems to be in the UOpenDoor class.

I verified the that I had unreal in the Epic Game Launcher so that is fixed! Now onto the actual coding issue, I’m working on that!