Unpossessed advanced vehicle continues input no matter what

If an advanced vehicle is unpossessed while a movement key is held then it will continue moving even if:
Input was disabled when the vehicle is unpossessed
“Throttle” variable was set to 0.0 when the vehicle was unpossessed.
@Burgess, can you look into this?

Hey Cowhunter,

It looks like the stop all movement node doesn’t work with this type of pawn which may be a bug. Thank you for submitting this post. I have reproduced this issue and logged a report for it here: Unreal Engine Issues and Bug Tracker (UE-40078)

You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

I was able to get around this by blocking the input axis move forward using a custom event.


Then I set the throttle input to 0 and had to delay before unpossessing the vehicle or else it didn’t work.



  1. Create an AIController which does nothing but set the throttle of the controlled vehicle to 0 (in the tick)
  2. Unpossess the car from player controller
  3. Possess the car by your new AIcontroller

It seems that the movement component only receives the previous to the last throttle input. And after being unpossessed it ignores inputs.

It’s still not working in 4.16.2 even if marked as fixed.

I had the same problem and I solved it. I also posted an answer to this question, but I have already lost it. if you have at least a little perseverance, then here is a solution for you.first, download unreal engine from github. second, in visual studio or in Reader, find the function that is responsible for set throttle input for the car. there you will see a check for possession of a pawn. there will also be a comment in the code, why ue developers added this check to the code. If you don’t need it, and you don’t need it, then just comment out the part of the code that meets this “if” check. Recompile unreal engine from visual studio or recompile only the module that is responsible for the car. after that, everything worked for me. Unfortunately, I’m too lazy to attach screenshots and look for my full answer to this question.