Download

Unlit material completely black on lit viewport [SOLVED]

Hi,

really strange, the unlit material goes completely black

i create new blank project

  • create an cube
  • create an unlit material and apply

it’s all black when i am on lit viewport, but working when i am on unlit viewport,

thank you for your help.
Best Regards
Daniel

What’s in the emissive of this Unlit Material?

Hi,

thank you for your help,
i just promote the material emissive color and change the color.
is the brand new project , insert sphere , create material, change to unlit, and change color,

and it’s black…

i had an windows update, and it’s seem to start from there. but not 100% sure

I see you’ve yet to apply the changes to this material - could this matter?

hi,

i try to use a material from the starter content.
if i passe the shader in unlit i am getting all black

on the output log , i have this line but not sur if it’s the problem


LogMaterial: Display: Missing cached shader map for material bbbb, compiling. 

i tried re-install visual studio and unreal.
same issue i don’t know if it’s because the window 10 update

Thank you for your help.

Perhaps it’d better to resolve the issue with the most basic setup rather than jump into another material? Not sure why / how this escalated so quickly :slight_smile:

Really strange,
i open an older project and it’s working.

BUT… i just try on my laptop create a **automotive > new blank scene **and i make the same which as:

  1. import sphere
  2. create material,
  3. change to unlit
  4. change the emissive color
  5. apply.

and it’s black also …

it is a normal behavior ? and i need to set something somewere ?..
(my laptop as also had the last windows 10 update)

thank you for your help.

but what is strange , if you see on my first post , if i passe the vieport in unlit i have the right color. and goes black when i switch to lit.

i found something.

If i create a Game -> blank project -> blueprint or C++ it’s working
if i create a Automotive -> Blank project -> is not working .

thank you for your help .
best regards
Daniel

I wish I could help but I’m as confused as you atm. :expressionless: Or more.

Likely the advice I give out the most.
Racquire your engine files, from launcher.
Basically validate the engine install. Something is definitely incorrect.

FOUNDED !!!

After :

  • reinstalling unreal
  • upgrading visual studio 2019
  • refresh framework.net
  • update nvidia driver.

It was,
i changed the unit of light on the project setting (on modo i use the lux) and when i switch the default lux value for unreal is 75’000 lux …
i little to high :slight_smile: (i t seem a bug to me)

Thank you very much for taking the time to help :slight_smile:
Have nice day.
Daniel

ue4light2.jpg

2 Likes

Nice work! I’ve got similar problem, when i tried to make a light emitting material in standart product studio project from ue4 templates. And light sources was so bright that my material was completely black.

I had a similar issue and came across this thread - one thing for anyone else who’s experiencing this is to try plugging in their material to emissive, that worked for me (I am probably a noob but hopefully someone finds this helpful)