Unkown error, can't fix

No idea how to proceed, I can’t seem to package anything and whenever I try and add any form of C++ content (class or feature) It tells me there’s a validation error. I know what caused it, I tried to remove a C++ class that I’d up messed the code in (First Person character) but now I have no idea how to fix it, everytime I try to package it tried to reference .gen.cpp that don’t exist, does anyone know how to fix this? I would rather not have to start again…

I had actually tried that, think I must’ve properly messed up…! I ended up migrating my content over to a new project ignoring any C++ (hadn’t really used any anyway) and now all is good! Thank-you for replying!

Try rebuilding the project. Go to the directory for your game and on the top level there should be a file called yougamename.uproject. Right click that and select 'Generate Visual Studio project files"
The visual studio project still has reference to your c++ class even though you deleted it. Every time you delete rename a c++ file you need to do this.