Download

Unknown extension"umap" / Unknown extension "uasset"

Hi there

Can somebody please assist with the following problem?

I am trying to move content from a different folder to my UE4 project. The content was created by Digital Tutors as part of their UE4 training course. I have tried the following options to get the content into my project.

  1. Start a new project, using the file location of the existing files. I tried this so that I am able to migrate the content I wish to use. This was unsuccessful as only the standard UE4 files where created and none of the other files are showing.
  2. I have tried to drag the files I need into the content browser. This causes an error for all of the files contained in my folder - see screen shot.
  3. I have tried using “Show in Explorer” even though I can see the files I am still unable to copy/paste or move the files to my project - see screen shot

3ea130cdd62eecb9ae3e559ca0a48feb01c652fb.jpeg

To say this is frustrating is an understatement; I have search through your forums and support documentation but have not found 1 single piece of information that is helpful to resolve this problem.

Can you please let me know what steps I need to take to get this to work? You would think it would be as simple as dropping a file in to your project…but clearly it is not.

Thanks and I look forward to hearing from you.

You just have to copy all the uasset/umap files into your content folder (select all - ctrl+c - open your project content folder - ctrl+v) → you are just abel to import fbx/üng/… file. :slight_smile:

Thanks so much, working now :-)!

I’ll definitively check out your tutorials too!

Hey all,
I don’t understand this: I’ve seen videos where the author demonstrates dragging and dropping the material/asset/etc, directly into the the contents viewport.
When I do it, the icon switches to a copy icon when I hover over the content viewport, but when I release it I get the the message “unreal failed to import … unknown extension .uasset”
Why? why do I need to go out to Windows Explorer to do this?

don’t drag and drop into the project. put .umap and .uassets into the content directory of your project using explorer.

didnt work for me either

Use file explorer, not the ue4 content browser. You can right click a folder in the content browser and hit view in explorer to immediately get there.

Still not working for me. My uasset files are in the correct directory but dont show up in the content browser