Unknown exception - code 00000001

Hi,

Several minutes ago I tried to compile some C++ code in the editor and it crashed. Probably the code had some errors… Now I can’t open the project because at 70% it crashes and shows this error:

MachineId:AC7E3613438509748349258147F5F019
EpicAccountId:3aad689837df45e5ae9cffe78aa15b36

Unknown exception - code 00000001 (first/second chance not available)

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 2315] 
ObjectPro

KERNELBASE
UE4Editor_Core!FOutputDeviceWindowsError::Serialize() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
UE4Editor_Core!FOutputDevice::Logf__VA() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\misc\outputdevice.cpp:355]
UE4Editor_CoreUObject!FObjectInitializer::PostConstructInit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:2315]
UE4Editor_CoreUObject!FObjectInitializer::~FObjectInitializer() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:2179]
UE4Editor_CoreUObject!UClass::CreateDefaultObject() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\class.cpp:2591]
UE4Editor_CoreUObject!UObjectLoadAllCompiledInDefaultProperties() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:729]
UE4Editor_CoreUObject!ProcessNewlyLoadedUObjects() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:820]
UE4Editor_CoreUObject!TBaseStaticDelegateInstance<void __cdecl(void)>::ExecuteIfSafe() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:921]
UE4Editor_Core!TBaseMulticastDelegate<void>::Broadcast() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\public\delegates\delegatesignatureimpl_variadics.inl:1031]
UE4Editor_Core!FModuleManager::LoadModuleWithFailureReason() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\modules\modulemanager.cpp:431]
UE4Editor_Projects!FModuleDescriptor::LoadModulesForPhase() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\projects\private\moduledescriptor.cpp:370]
UE4Editor_Projects!FProjectManager::LoadModulesForProject() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\projects\private\projectmanager.cpp:52]
UE4Editor!FEngineLoop::LoadStartupModules() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\launchengineloop.cpp:1922]
UE4Editor!FEngineLoop::PreInit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\launchengineloop.cpp:1444]
UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\launch.cpp:110]
UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]

What can I do? It’s a bit important for me to get this working again as soon as possible because it’s a project for the university :confused:

Thank you in advance!

Hey Guilledi,

Thanks for providing as much of the log that you did, I was able to track down the error that you’re receiving. This is an issue we’ve ran into a lot lately it’s classified in Jira as UE-18041. This bug has been fixed and closed but it will not be released until 4.8.2. The fix for this bug is to provide a better warning on what’s actually happening with your project so we can figure that out.

With that being said, since you’re not able to open your project back. Do you have an older copy that you’d be able to open? If not, please go into the project folder and delete the following folders: Config, Intermediate and Saved folders. Once you’ve done that, please try to open your project again and let me know whether or not that has worked.

If it does not work, please feel free to restore those folders and upload the error as a .txt file to your next reply.

Looking forward to hearing back from you, thank you for your time!

Hi Samantha,

Unfortunately I didn’t do any backup copy… :frowning:

I deleted those folders and tried to open the project. It didn’t work, but the first time it showed an error a little bit different from the other one.

I upload 2 files: the first one is the first error I got, the one that is a bit different. After that I keep getting errors with the “Unknown exception - code 00000001” just like before: second file.

Looking over the logs, I noticed this being part of the fatal error.

Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 2315] 
ObjectProperty /Script/MyProject2.AI_Character:shotOrigin must be initialized in the constructor (at least to NULL) by calling ObjectInitializer.CreateDefaultSubobject

Would you be able to look in the UObjectGlobals.cpp at line 2315 and see if there is any error you can pinpoint?

Okay, I think it was a noob error. In Visual Studio the output shows these errors, instead of the other one, so I think I got confused:

“error LNK2001: unresolved external symbol “protected: virtual void __thiscall AAI_Character::PostEditChangeProperty(struct FPropertyChangedEvent &)” (?PostEditChangeProperty@AAI_Character@@MAEXAAUFPropertyChangedEvent@@@Z)”

and:

C:\MyProject\Binaries\Win32\MyProject2-Win32-DebugGame.exe : fatal error LNK1120: 1 unresolved externals

To solve that error I tried to add new modules to MyProject.build.cs:

PublicDependencyModuleNames.AddRange(new string[] { “Core”, “CoreUObject”, “Engine”, “InputCore”, “RenderCore”, “ShaderCore”, “RHI” });

but it does not work. What can I do now?

Thank you for your time!

Okay! I solved it.

It was a combination of errors: I was building with the wrong Solution Configuration and I had some errors compiling.

After fixing that, the project launches again :slight_smile:

Thank you!

I’m glad you were able to fix the issue you were experiencing. If you happen to have any further questions, please feel free to submit a new question to AnswerHub and we’ll be more than happy to help you further.

Have a great day! :slight_smile:

Please, tell how to fix this problem?!

Guilledi posted below stating he had a combination of problems including: building the wrong solution configuration and also had compiling errors.

If you’re unable to resolve this issue on your own, please submit a new AnswerHub thread and we’ll assist you further. Make sure to put your question in the right category/section.

Thanks!