Download

Unknown Cook Failure

Good morning.

So I’m having an unknown cook failure when trying to package a game. I’m not sure why. I have read that it has to do with blueprint errors but nothing specific.

This is a C++ game, engine 4.10.1, output log is http://pastebin.com/55L4XVb3.

I get the error LogLinker:Warning: Can’t find file ‘/Game/BPNetworkingProject/ThirdPersonOverview’

I’m not sure why, I don’t have that folder or that file/BP and never have. Is that something that is autogenerated?

It seems to actually fail in an assertion in SharedPointer.h line 728


	/**
	 * Dereference operator returns a reference to the object this shared pointer points to
	 *
	 * @return  Reference to the object
	 */
	FORCEINLINE typename FMakeReferenceTo<ObjectType>::Type operator*() const
	{
		check( IsValid() );
		return *Object;
	}

Is there a bad reference somewhere? I have tried refreshing the nodes in all blueprints. I also tried fixing up redirectors in all folders. I’ve cleaned and rebuilt the project and deleted all the folder I could as well as regenerating the project files. There are no load or map errors.

Does anyone know of any other log files that may help or what these errors may be from?

Are you using the ThirdPerson template by any chance?
I’ve had a quick look at it and there appears to be ThirdPersonOverview.uasset located in [path to engine root folder]\Templates\TP_ThirdPerson\Content\ThirdPersonCPP.

I don’t exactly know why you’re unable to cook/package your game though. The output log you posted does suggest to see the log file AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+4.10\Cook-2015.12.14-05.44.23.txt

I used a sidescroller template. Is there a good tutorial on how to go through all the stuff that’s included that you don’t need and can remove?

Unfortunately I don’t have that log file anymore and now when I try to build I have Error Unknown Error. Even more ambiguous. I am trying to read those error files in that directory but I can’t seem to get any more useful information from them.

And when I try to package this project I get an error in my file which talks about a different project “…EmptyLinkFunctionForStaticInitializationAIFlightTest…”

UnrealBuildTool-2015.12.14-12.43.03.txt

UBTManifest.0.xml

UAT_Log.txt

So I went through the .cs and checked every bit of every blueprint and redid a ton of stuff and tried to build all day.

I don’t know why but the project doesn’t seem to be looking for the thirdpersonoverview blueprint anymore. It is also not trying to resolve dependencies from another project (wtf?)?

This is my cook log file:

I’m still looking into it

I’ve tried 4.10 from source and 4.10 from the launcher.

I’ve tried VS2013 and VS2015.

I’ve tried using and not using the pak file.

I’ve trying debug, development, and shipping package.

I’ve tried deleting the ddc and all the other things that can be deleted.

Thought, or thoughts?

I think the culprit is paper2d. I had it enabled initially but disabled and removed it but now there are bits all over the place referencing paper 2d. I did a notepadd++ search in my project directory and got about 4000 hits in 58 different files.

Is there a guide or list of files somewhere that talks about removing every reference to a plugin like that?

Error caused by disabled plugin.

I had disabled the Paper2d Plugin and something was still trying to reference it. I had tried to re-enable it but it didn’t work for some reason so I rebuilt everything from scratch and re-enabled paper2d and now it will package.

I’m still not sure what is looking for paper2d and would like to disable it.