Download

Unknown Cook Failure

Good morning.

So I’m having an unknown cook failure when trying to package a game. I’m not sure why. I have read that it has to do with blueprint errors but nothing specific.

This is a C++ game, engine 4.10.1, output log is http://pastebin.com/55L4XVb3.

I get the error LogLinker:Warning: Can’t find file ‘/Game/BPNetworkingProject/ThirdPersonOverview’

I’m not sure why, I don’t have that folder or that file/BP and never have. Is that something that is autogenerated?

It seems to actually fail in an assertion in SharedPointer.h line 728


	/**
	 * Dereference operator returns a reference to the object this shared pointer points to
	 *
	 * @return  Reference to the object
	 */
	FORCEINLINE typename FMakeReferenceTo<ObjectType>::Type operator*() const
	{
		check( IsValid() );
		return *Object;
	}


Is there a bad reference somewhere? I have tried refreshing the nodes in all blueprints. I also tried fixing up redirectors in all folders. I’ve cleaned and rebuilt the project and deleted all the folder I could as well as regenerating the project files. There are no load or map errors.

Does anyone know of any other log files that may help or what these errors may be from?

Yeah, that looks to be a bad reference in your C++ code. Check your constructors, etc for references to that file.

The actual error is that a specific TSharedPointer requires a valid object (created from that missing file), and the check(IsValid()) failed, triggering an assert.

Run a search through your project’s entire code for the file’s name; if you find a reference(most likely in a ConstructorHelper call), remove or fix it as necessary. If you don’t have a reference, you may need to delete your DerivedDataCache, or DDC. I cannot tell you how to do that, but a search of the AnswerHub should be sufficient.

I searched through everything with notepad++ and didn’t find anything. I had also already deleted the ddc as well.

Now I’m getting even more ambiguous errors saying it cannot resolve external dependencies with the name of a different project I have that will package. That doesn’t make sense to me!

Has anyone else experienced something like this? I have spent about 12 hours on it and cannot seem to find a solution.

So, just to clarify, are you trying to build the LittleRockets_CPP project or not?

Your log looks like it is trying to link with the definitions for several functions, and not finding them. It looks like it is failing to find generated code for the Substance plugin and an “AIFlightTest” (plugin?). If you have those plugins, you may need to try disabling them in the project settings.

As a general piece of advice, I would suggest verifying your UE 4.10 installation via the Launcher.