Download

Unknown Cook Failure while packaging

Hello one and all,

I’m having an issue while packaging my game demo in UE4.21.2 (for windows). The cooking process keeps giving me an unknown cook failure.

I set the packaging options to shipping, full rebuild, my maps and modes are set. There are no redirectors.

I tried packaging a blank third person project, and it works.

I tried removing saved and intermediate folders. It doesn’t work.

I tried removing saved, intermediate and config folders. It doesnt work

I tried rebuilding every single level’s lighting, It doesn’t work.

I tried removing all the warnings (missing files), and it does still not work.

I tried moving the project to the root of my hard drive, in case of long names. It just failed again.

I tried launching the project from the Epic Launcher, and it still did not work.

I tried deactivating the one plugin i use (Dungeon architect), but it gave me a TON of actual errors, and did not work.

So here i am, staring at my logs and cook files, but i can’t seem to find the culprit.

What am i missing here? Any help would be greatly appreciated.

Cook2019.05.2017.08.21.txt (288 KB)

Log.txt (339 KB)

PS: I also posted the same question on answerhub, here’s a link to the topic: https://answers.unrealengine.com/questions/897952/view.html

Hi, I had a similar problem and resorted to a sledge hammer tecnique.

Clone your project, try to package.
If Fail… delete everything in the content folder, try to package.
It should pack OK.
Migrate your project level(s) to the clone, try to package.
If Fail…
Delete some folders from the content folder, try to package.
If Fail…repeat deleting more folders.
Eventually you should get it to package, that means the problem file(s) were in the last delete.

clear content folder and migrate only the last delete folders back in., try to package.
If Fail…
delete each folder one at a time , try to package.
If Fail…

Eventually you should find the folder.

Clear the content folder, re migrate your levels back in, then delete the troubled folder (file) , try to package.
It should package , so now you know where the problem is
sort out / remake the file(s) in question

Sounds very long winded, but I managed to narrow it down in a 5gb project in a couple of hours.

Paul G

Hey Paul,

Thanks for the suggestion! The sledgehammer pointed in the right direction :slight_smile:

After breaking down my project folder by folder, i ended up packaging successfully the project but had to deactivate a plugin and remove all the gameplay maps (which rely on said plugin).

At this point i am guessing there are specific steps to follow i didn’t know about, while packaging a game with a plugin from the marketplace.

Do you have any idea about that?

Again thanks for the hint, it really helped narrowing it down.

I have not found anything to specific on packaging with plug ins, however I do consistently have problems with marketplace plug ins.
Generally once I get the project to a certain stage I clone it, then delete everything in the content folder before migrating the levels back in.
This essentially gives me a clean project with no unused files…
I then switch off all plugins restart and then switch them back on .
Finally I delete the saved and intermediate folders before I attempt to package.
I then check the package log and try and work through any warnings/ errors
Its not always possible to remove warnings (least I don’t know how to get rid of version warnings for plug ins)
Best of luck seems your problem is with the plug in as it affects all levels that use it… contact the supplier ?

Paul G

Man thanks a lot for your time,

I will try cloning before packaging, and if that fails i will definately contact the supplier.

It seems it’s not easy for you either to package plugins, best of luck to you too!