Download

Universal AI Behavior Toolkit

Now Available on the UE4 Marketplace

**https://www.youtube.com/watch?v=[/SPOILER]

A possibly fix for above mentioned AttackeMeleeDistance issue (increase delay prior to setting the defaults).
Everything seems to work now smoothly, but didn’t tested the parkour system. Edited the spawner to respawn AI, and slightly adjusted related OnDeath spawn handling. If someone wants that code, post below.

@Jujaswe We ran into a problem. Our Physics Objects has a root that is a SceneRoot, Then under that we have a StaticMesh which is simulating Physics. So whenever Seek is called, it will run to the Actor Location (which is not where the StaticMesh is). For now we solved this by spawning that mentioned invisible NoiseActor which has the Approriate Tag on it. It however destroys it self after 5 seconds, which sometimes means that the NPC’s don’t reach it before it has despawned. When that happens, it seems like the BT gets stuck and can’t transition out of Seek. I added a PlaySound2d to end of BTT_MoveToBlackboard (as shown) and after a while (when NoiseActor destroys), this sound will play constantly, while the BT will be stuck in Seek.

Please advise…

Edit: I worked around the issue by not destroying the NoiseEmitter Actor at all. It obviously adds some overhead, but works. Would be nice to get your oppinion on it however.

@Jujaswe - super quick suggestion for the next update. Can you have the NPC that spawns a projectile be set as the owner and instigator of that projectile? (see attached pic)

In my projectiles, I tell them to ignore collisions with their owner so an enemy can’t shoot itself but can accidently shoot other enemies - Doom style.

Thanks!

this is blueprint,Maybe it’s my fault

I try to change TargetsConsiderationRadius ,when I change his value,it’s no effect.

This is my way,TargetsConsiderationRadius is 0 when AI moves and TargetsConsiderationRadius is 3000 when AI stops moving!

Find a lot of mistakes,but I haven’t changed the OwningCharacyer and ControllerRef,I don’t even know what it is,It just popped up in the morning,I hope you can help me,thank you!

This is in English

I just always got error message after migrating into my project.(when open the project)
“Can’t find file for asset”
I would be grateful for any idea why i got this errors.
Thank you!

NZ-casinos Review of casino are redefining the online casino experience by offering you big name games and progressive jackpots from the likes of NetEnt, Thunderkick, WMS and Bally plus an out of this world player experience to top it all off!

Hello! I’ve been using your kit for a while, just recently created a new project with 4.18 and planning on using your kit for it again. I’m now getting a bunch of errors. I’ve made sure EQS is ON and I’ve even created a new AI Behavior Toolkit project and copy/pasted everything over to my current project, overwriting it. Is there another EQS setting I’m missing? I’ve looked through the FAQ PDF over and over, can’t figure this out. This is what’s “missing” even though I clearly see them all in their folders in Explorer:

That checkbox isn’t the right one as I see there @Yaremko, so go to the “Editor Preferencies” ➠ “General - Experimental” and there check in that block on the attached picture:

I think that is the problem with your project.

Collision seems alright, checked all that before asking.

I’m using FPS Kit. In step 7 on the Integration doc from FPS Discord says to do first image:

But, that doesn’t work. Target on Add Actor defaults to Self and won’t allow GET, and Actor Ref won’t allow Self, but will allow from GET?

So, I tried the second image just now.

I spoke to FPS dev, he said it’s an optional step. Not sure what to do other than test this last logic.

It Step 7 optional? If not, is my code worth anything, cause, as it is, step 7 is not possible.

@RoccoFX thanks for the feedback!

  1. You can change the AI’s Movement Mode to “Walking” and behavior tree when you want them to walk. And then when you want them to fly again, just change back to “Flying” and the original behavior tree.
    [ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_156809_1548941876873_827”,“title”:“AI22.JPG”}[/ATTACH]

  2. You could add to the BTS_CheckDistance to check if they are too far from where they started. Then call “Change Behavior” to force them into Idle.

  3. Just change the Rotation Rate from the Character Movement component. Like this -
    [ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_156808_1548941911354_584”,“title”:“AI21.JPG”}[/ATTACH]

I hope this helps.

Hello!
I have a problem with the amount of AI Actors I can spawn.
I can only have around 50 working AI actors, the rest is just standing still.
This is a problem I have for a long time and I could not fix it myself. I need more actors to populate a more open world but it is not working with 50 actors.
The errors do not appear every time and I think it does not have much to do with it though.

I would love to fix this issue somehow.

Hello, has anyone had any luck or found way to adjust enemy FOV/field of views? I can’t find a way to limit FOV on enemy AI to 180 degrees or less, I do have line of sight checked, but by default it appears to be a 360 collider that detects the player?? Can anyone please help on how to adjust this? Would like to achieve some sneaky stealth kills :slight_smile: