To be more specific, GetFName() would be more appropriate as the name is returned as FName instead of FString, making for much faster comparisons and lookups.
FNames are not as “unique” as, say, GUIDs, but some rough assumptions you can base yourself on is that you will only have one actor by a given FName in a level, and you will only have one component by a given FName on an actor.