Unhandled exception when building blank project: Version ("1.2") is not supported version

Unfortunately, I’m having this problem and this didn’t fix it for me. Using 17.2, but not the preview version, installed the older compiler, used your XML, but still getting the json error. The only way I can find to fix this is to do a full rebuild every single time.

Thank you @dkjb63411 ! This solution worked for me without changing the version manually on all .json files.

@HERO4K60 Check this article showing possible locations for the BuildConfiguration.xml Build Configuration | Unreal Engine Documentation
I put mine on in [USER_DIR]\Documents\Unreal Engine\UnrealBuildTool. I just had to fix the quotes and remove a trailing 21 in the xmlns declaration. After that I had to modify my VS install to include version 14.31 of the compiler and finally did a clean/rebuild.


Unfortunately, I am in the same boat as JasonEldred. Not using the preview version and the UnrealBuildTool just disregards anything in either the appdata folder and the my documents folder.

Requires me to do a full rebuild every time.

The fix actually did work for me. Must have been tired since I had every toolset Except the one I was trying to target.

1 Like

thank you. Worked for me

Will there be any problems if I keep this file like that, I mean with unreal updates or will this file be overwritten?

1 Like

I would hope a patch or fix makes its way into the engine source. I do believe that I’ve seen a few pull requests up to address it.

The next time there’s an update from epic, revert back to using the default latest compiler and see what happens.

thanks – what i did is installing an old 2022 version with offline installer and it works fine now - until epic support 1.2 officially

I just uninstalled VS 2022 C++ build tools (Latest) and installed one of the other versions and it works for me


When I try to remove this version of BuildTool, the VS alert me that the other components like “Graphics Compiler / Unreal Engine Installer” will not work anymore… How do you set this to early version and get Unreal Engine compiler working well?

I just proceed with the uninstallation despite the warning and install a previous version of the build tool and it worked

1 Like

You can leave the latest compiler version installed, as long as you update your build configuration xml to use an earlier version (posted earlier in the thread).

1 Like

I saw an update to visual studio 2022 this morning (ver 17.2.1) and tried reverting to latest build tools and it seems the error is gone (for me at least)

1 Like

Thanks for the update I’ll have to try it tonight.

Did it work? Running into this issue right now

Thank you. Installing the older version of msvc works for me.

Just remember to clean the old build, regenerate solution file, rebuild, or even delete the .vs folder and everything like that. Then rebuilding the solution should work.

I can confirm rolling back the compiler works.
With these additions to the BuildConfiguration.xml

<?xml version="1.0" encoding="utf-8" ?>
<Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">

Thanks, Matt! I’m curious to see when they’ll fix, so I’ll need to roll back the xml to its default.

1 Like

Rolling back the compiler with those additions doesn’t help unfortunately.

Would rolling back to a previous VS version like 2020 or 2019 work? I’m not using VS right now for my project and i just happened to download 2022 after a system format…

Answered my own question, VS2019 doesn’t work lel

It’s not gone, the values still set themselves to 1.2 every time you recompile

Hello, I am having this same issue even after rolling back to a previous compiler. Wondering how you are getting it to work. What exactly do you mean by doing a full rebuild every time? Is this just rebuilding in unreal engine again before packaging?

Hey you still getting the same error? I am still getting this error after trying everything wondering if you solved it? Did going back to UE4 work for you?