Undo-ing takes Blueprint back to 0,0,0

There’s an extremely weird behavior being exhibited in this blueprint.
When you undo the blueprint in the world editor ( either when you move/rotate ) . The Editor somehow strangely brings the Blueprint back to 0,0,0 regardless of where the object is.
I’ve tried for hours trying to figure why is the behavior as such.

I’ve deleted everything and isolated the ONLY function the blueprint has is a
function that spawns an instancedstaticmesh on the construction script.

Even reset- all var to default. deleted all custom functions.
I’ve also moved it to an empty project I just created and it’s still the same thing.
Making copy of the blueprint results in the same problem

However, I wouldn’t say this is fully reproducible because creating an exactly new asset with similar function does not cause the same error.
Please examine the blueprint asset to see if this is a genuine bug or there’s something strange I did. link text

Bumping this thread. I’ve a attached an asset. I hope an epic staff can get this examined.

Hi ,

Are you still experiencing this error in 4.6? If so can you tell me what steps to take to reproduce this on my end? Thank you!

It seems to be no longer there for some time. It just went away.