Download

Undeside of this dark

Not sure why the undersides of all my interior surfaces are dark. The normals are all pointing downward. Is it because I do not have any interior light sources in the scene yet? I would think that there would be enough indirect lighting bouncing around to light the undersides at least enough so they are not so dark.

dar ceilings.jpg

The underside of all my meshes are black… So it must be a lighting issue. All my light maps are good.

You are using dynamic lighting i assume? If that’s the case disable Lower Hemisphere is Black in movable SkyLight’s properties. This isn’t the best way to light interiors though.

I noticed I was getting a double shadow with one directional light. I deleted the directional light, brought in a new one and made sure dynamic indirect lighting was enabled and now all seems good.

Edit: Nope still black after light build.

You shouldnt be building lights for dynamic lighting. Enable Force NoPrecomputed Lighting in World Settings and then Build once to get rid of static lighting. Now you can start playing around with your movable light sources. Also keep in mind that you can use reflection capture actors with dynamic lighting, which helps blocking skylight reflections for interiors.
There are a couple of dynamic lighting solutions with GI(LPV, HeightfieldGI, VXGI, DFGI) but i really doubt any of them will give you the quality you would have with Lightmass

Yes, I really think my problem is I not sure how my light set up should be for my project. When I first set this up it was just with static lighting. Everything looked great. I wanted to have a day/night cycle continuously running. I got one from the market place. This when things started to get different. In my set up I have the day/ night cycle blueprint, skysphere blue print, directional sun light, atmospheric fog and skylight. directional light is set to movable. I have a light mass importance volume. Do all my mesh objects need to be set to movable? I do not see the option for Enable Force NoPrecomputed.

That day/night cycle BP may have a directional and skylight in itself as well, so that may be one of the problems. Check out the components in that BP and delete the directional and skylight in your level if it already has those.
Lightmass importance volume is required for static lighting only, and no, your meshes can stay as static.
The parameter is called Force NoPrecomputed Lighting, you need to enable it in World Settings and then build the lights only once to get rid of the lightmaps.

In the day/ night Cycle BP, you link the sun light and sky sphere you bring in to your project. So should I delete my light mass volume? What is the better solution for arch-viz dynamic or static? I spent a lot of time making the uv light map channels on all my objects. Do I want dynamic because of my day/night cycle? I have watched some tutorials and read some documentation but I can not get a clear picture as why to use static vs. dynamic or vise-versa.

For the life of me I can not find the Force NoPrecomputed Lighting in the world settings. I am using 4.8.2. Has it moved? Do I need to be running a experimental version?

Thanks for taking the time to help…

For interior arch-viz static lighting would be the best. You could build two maps, one for day time and another one for night time and present them as separate levels. But if you really need/want day and night transition than you’ll have to use dynamic lighting.

Search that Force No Precomputed Lighting parameter in the search bar of World Settings and you should be able to see it now. It is under Lightmass section.