Download

Unavoidable Light Leaks

Hey everyone, so ever since mulitbounce was introduced in engine I’ve found it nearly impossible to get rid of light leaks from point lights and spotlights, directional light aswell but less likely and a lot easier to get rid of. I’m very surprised there isn’t a topic on this already how big of a problem this is. I have created a test scene to give an example of the issue. I have tried creating every type of walls possible and it makes no difference I’ve tried every setting and researched every solution and nothing has worked the only solution to this is having Num Indirect Lighting Bounces set to 1 that will complexly get rid of every leak which isn’t realistic at all and the actual number of skylight bounces has little affect on the leaks, the indirect lighting quality helps get rid of some as well but it doesn’t completely solve it I’ve tried many of scenes I have done, made many test scenes and tried this on ue4arch and Evermotion scenes and its always the same outcome , anyone have a solution to this besides having less realistic lighting?

Ok so here is koolas light scene I copied the point lights from the nighttime map in this project and rendered it with the same settings except 5 skylight bounces I can use any scene you want me to I can even try the epics scene they did and I guarantee same results

Now here is epics architectural scene same settings exept I tweaked the light mass settings like koolas scene above and added another spotlight in the hallway, how can this be explained? Cant be the walls shouldn’t be the spotlight or point light settings in either case same ones epic and koola used no different.

That is correct about koolas scene and it does create bleeding black lines but that’s irrelevant to these leaks they have no relevance to each other whether your walls are perfect or not you will ultimately get these leaks if you set up lighting correctly multibounce that is, which your picture something looks off about it firstly you have a blown out pointlight which I originally was testing with the already placed spotlights in the scene they provided since they already were properly set up intensity wise for the scene and your scene seems a lot darker like you don’t have the multibounce even set up correctly it looks totally different I tried to emulate what you did but you didn’t give any info about your settings, I am still using same settings I’ve mentioned twice above now.

I have got the same issues even on high baking settings they aren’t gone and there is no issues with the meshes