Unable to Update to UE4 v4.7.5


I’ve been attempting to update for 5 days to v4.7.4 however I continually get the issue of “Please wait” or “Install Failed: The installer failed to initialise”. I’ve tried cold rebooting my PC, disabling and re-enabling Internet, and entering and exiting my project however it isn’t updating.

This is a pretty annoying issue which I’m guessing is related to the Epic Games Launcher or something. Right now I’m using v4.7.3 and it seems to be working fine however under “My Projects” it is currently listed as “Other” instead of “4.7”, although it still loads under v4.7.3. Considering that there’s now been two engine updates which I haven’t been able to install this is getting very frustrating.

Hi Icaraeus,

Try the troubleshooting steps in this section of the Launcher guide.

If nothing works for you, follow the steps towards the bottom of that link and generate your Debug Logs. Then post them here.

Fixed it. Running the launcher in Administrator Mode resulted in the launcher updating some 130mb file before opening and then I was able to update.