Download

Unable to set 5120x2880 in fullscreen in latest UE4 games.

I’m unable to set my native 5120x2880 resolution in fullscreen mode in various newer UE4-games, like Fade to Silence, OVERKILL’s The Walking Dead, Life is Strange 2, What Remains of Edith Finch. It automaticly switches to 2560x1440.
I am able to run 5K in windowd and borderless window mode, but SLI give lower perf. that way.

Older UE4-games like, Inner Chains, Agony and many more are working without any problems.
The monitor in this case Philips Brilliance 275P4VYKEB/00, uses multistream transport ie acting as two on two displayport connections, so only rendering with one as 2560x1440 is just the halve?

OS is windows 10, 1903, build 18908rs.
GPU’s 2x2080Ti.

I tried to disable fullscreen optimizations, but that seems to be impossible for these games, FSO continiue to be active :frowning:

Does anyone knows how to get this issue solved?

That’s something that’s up to the developers if they want to add support for a specific resolution

Ok, so nothing I can do? A games should support my native resolution normally I thought? Thanks

The game developer can (and often will):

  • override common engine functionality to fit their own
  • change the engine with features not previously found or remove certain features if they see fit a purpose
  • disregard screen resolutions which they didn’t test the performance optimizations done for the most used resolutions

The best approach would be to ask them if there is anything you could do or if they could provide a patch that would enable this soft of behavior.

I recall some UE4 games support adding custom resolutions via editing the .ini settings, but it might not work for all games.

The fact is, the res. is given in the menu, but isn’t accepted, it switched back to 2560x1440, which let me believe there is a bug involved with mst devices. Earlier UE4 games acted the same for a while…
Editing ini settings didn’t help.

Have you tried it with SLI turned off?

Will check this. One note; setPreferredFullscreenMode = 0 worked in Call og The Cthulhu.

Single GPU is the same, plugging one displayport cable off, changed it a bit, ie I can select some resultions, so I really believe it lies in the behavior of the later engine updates, 4.17 and older, as former builds don’t have this issue. I hope someone will take the effort to look at it again, despite the small userbase.

Is there any other place I could contact about this issue?

Your best bet is to contact each developer directly and ask them. There’s nothing Epic can do.

Thanks, but I did this and one from the “Draugen” developers said available resolutions will be generated/read from the engine, which read it from Windows?:

It’s also not a coincidence all the latest UE4-games act this way? Could it be WDM acting wrong?

The list of available resolutions are different if you are in Full Screen and Windowed Full Screen. If the game is only able to use the Windowed Full Screen the list of available resolutions will be shorter than otherwise. If the game can’t use the Full Screen mode, you need to contact the game developer.

Epic will never touch someone’s else developed product or interfere, since this is not ethical.

Well, in some games, Life is Strange 2, the list for fullscreen does appear, but it won’t accepted, it reverts to a standard res like 2560x1440 or 1600x900, infact in that game and a few, no fullscreen resolution does accepted ever, it revert always back. At the very beginning of Unreal Tournamen Alpha, it acted also like that. As if high dpi is rejected, though I have High DPI-scaling ignored in the app properties.
Well, I will try to get help from a dev. but it seems not many have the time or are intrested. Offcourse the fact this is not widely used hardware is not in my advance.

btw, the are my game user.ini settings for Life is Strange 2 for example:

bUseVSync=True
bDNEFirstLaunchSettings=False
ResolutionSizeX=5120
ResolutionSizeY=2880
LastUserConfirmedResolutionSizeX=5120
LastUserConfirmedResolutionSizeY=2880
WindowPosX=-1
WindowPosY=-1
FullscreenMode=0
LastConfirmedFullscreenMode=0
PreferredFullscreenMode=0
Version=5
AudioQualityLevel=0
FrameRateLimit=60.000000
DesiredScreenWidth=5120
bUseDesiredScreenHeight=False
DesiredScreenHeight=2880
LastRecommendedScreenWidth=-1.000000
LastRecommendedScreenHeight=-1.000000
LastCPUBenchmarkResult=-1.000000
LastGPUBenchmarkResult=-1.000000
LastGPUBenchmarkMultiplier=1.000000
DNEFramerateCheckQuality=1
DNEMeshScattererDensityFactor=1.000000
bUseHDRDisplayOutput=False
HDRDisplayOutputNits=1000

I get almost no reaction from any developer. I have iron it out on UE4-versions from 4.16 and higher. All games made with 4.16 and higher act like this on my machine (at least 6 on my HD), that’s not a coincidence, and I don’t mean its intended by anyone, but a common bug. I’m a long time enthousiast UE-user from the days of Unreal1 and it’s a pitty that’s it going this way.

Thanks for all the answers though.

The engine reads the available resolutions for the primary monitor. If your thing pretends to be 2 monitors, it won’t work (obviously). Most developers are going to use whatever the engine says is available, so this really doesn’t concern them (it would make no sense for lots of individual developers to change the same thing in the engine).

If you’re really sure this has worked in older engine versions, try submitting a bug report.

^ Yes older versions, V 4.15 and older, are working flawnessley. I already subit this bug a few weeks ago, here https://epicsupport.force.com/unrealengine/s/
but haven’t got a response.

Strange - there aren’t any changes to the resolution detection code between 4.15.3 and 4.16.3 from what I can see.

Maybe the engine has problems acting with mst (multi stream transport) monitors, they act like two, surround (or eyefinity in case of amd graphics)?