Unable to run community plugins when packaged.

Hello UE4 Community,

I have an issue possibly with my UE4 or PC environment. I have tried a couple of plugins made by the community which work fine in the editor however, if I try to package them for development or shipping, they do not work. The following message reads…

“Plugin ‘PluginName’ failed to load because module ‘PluginName’ could not be found. This plugin’s functionality will not be available. Please ensure the plugin is properly installed, otherwise consider disabling the plugin for this project.”

For example, I installed the Razer Hydra Plugin and followed a Youtube tutorial on how to install the plugin listed below…


After following the tutorial on how to place the plugin into the game projects folder, I have not been able to package a game in development mode or shipping where the plugin is working only in the editor.

Some helpful clues hopefully,
My “Documents” folder resides on my E Drive due to ever expanding projects. Is it at all possible that the launcher or some other execution tool cannot see the plugin when running the game? And if so, how would I go about pointing to that folder?

I tried packaging the game with Pak files enabled and disabled. Neither works for me. If it is disabled I can actually see the plugin packaged in the folder but somehow when the game is running, I still get the message posted above.

One last observation, I pulled this line from a log if this makes sense to anyone familiar with this situation.
“LogModuleManager:Warning: ModuleManager: Module ‘HydraPlugin’ not found - it’s StaticallyLinkedModuleInitializers function is null.”

I appreciate any help or clues to what may be the issue or a mistake I am making. Thanks for your help.


I have had similar issues attempting to package my own and other plugins. The only context that I can get a project to package with the plugin found is the code project itself that is used to build the plugin. It has no problems finding the module.

This situation is less than ideal as we want our artists to be able to leverage the functionality of our plugin without having to go anywhere near Visual Studio or the build process.

Well GerardD, you just made my day. I went ahead and created a C++ project and it worked. One thing I noticed as it was packaging, the log showed the plugin building under the UnrealBuildTool. So I think it might have to do with the UnrealBuildTool not being able to find the plugins location when using an editor only project. I will give you credit for answering the question. But we can still discuss any further progress on this post, or if anyone else has additional information.

Thanks again,


#Epic ?

Epic any thoughts on how to get around this limitation of plugins?

Doesn’t this mean that people can never ship a game with a plugin they dont have the whole source code for?

And what about people with content only projects who cant use Visual studio?


How can I market plugins that only people with c++ projects can use in a packaged build?

+1, we really need to be able to load plugins from non-C++ builds!

Well, following the steps in this post UE4.3 and the Substance Plugin
got me somewhat further. (Compiling took me 30 minutes mind you, and you need to have the source code from github, which also takes half an hour). Now if I try to package the product I get a problem that it can’t find KISS_FFT. Well i was not working anyway, so I just try something else.

Hi everyone,

I apologize that we did not have a response for this post sooner. I did some playing around with adding a plugin to a project (using getnamo’s Hydra plugin in version 4.5.1 of the Engine built from source code) and tried packaging projects in various scenarios (development configuration, project created in different locations on different drives). If I placed the plugin in the project folder, I was able to package the game without any problems. If the plugin was placed into the Engine folder, then packaging failed. I saw the same results in a couple tests using the binary version of the Engine.

Would you be able to provide more information about what plugin you are trying to use, where you are placing the plugin, where the project and Engine are located, and the settings you are using when packaging?

Thanks for giving this a look.

The use case that is problematic for plugins is in regard to users who might not access to the source of the plugin when they come to packaging their project. This might be the case for plugins that are not necessarily open source. The plugins modules can be accessed by projects when working in the editor for development but as soon as there is an attempt to package that project the build can fail either at the build (in a code based project) with the error:

  • " UnrealBuildTool: ERROR: Couldn’t
    find referenced module ‘PluginName’ "

or it fails at launch in Blueprint projects with the message:

  • " Plugin ‘PluginName’ failed to load
    because module ‘PluginName’ could not
    be found. Please ensure the plugin is
    properly installed, otherwise
    consider disabling the plugin for
    this project "

The log file for that same launch of the blueprint project states:

  • " LogModuleManager:Warning:
    ModuleManager: Module ‘PluginName’
    not found - its
    function is null. "

This is the use case that prompted my queries and I believe some of those earlier in this question.


I was able to see the second error you mentioned using getnamo’s Hydra plugin when using a Blueprint project created with the Binary version of the Engine. That was corrected by adding a blank code class to the project and building the resulting solution before packaging again. I was unable to see the first error message in a code-based project. Is there a specific plugin that you are using that I can test with?

Hi everyone,

We have not had any new responses to this issue for a while. Is this still something that is affecting you? I will be marking this issue as resolved for tracking purposes, but if you still need help with this please feel free to re-open the issue.

I have the same issue.

Download 4.8.3 binary. Add JSON Query plugin to your project plugins (not engine) try to package the game. It will be packaged but .exe can’t find the plugin it tells that it isn’t installed.

Hi intoxicat3,

Are you using the binary version of the JSONQuery plugin? When I tested using that version, I saw the same result that you described. However, when I tried using the source code version of the plugin, the packaged project seemed to work fine.

Hi ,

I’ve recently been trying to integrate a .dll into my plugin. I have been getting the issue “the program can’t start because .dll is missing from your computer”, I have placed it in a folder (Project/Plugins/PluginName/External/lib/.dll) and provided this location as below:

string pathString
RuntimeDependencies.Add(new RuntimeDependency(pathString));

Once clicking okay on this message, I get another window telling me “Plugin ‘PluginName’ failed to load because module ‘ModuleName’ could not be loaded. There may be an operating system error or the module may not be properly set up.”

I have checked that all paths are correct and there are no compiler issues. There is code in the other parts of the plugin (PluginName/Source) and there is a header that came with the .dll to access functions (PluginName/External/include/provided.h).

Could you please suggest any solutions to this problem? A swift answer would be appreciated :slight_smile:

Best, Sam

PS, I am using 4.10.4 if that helps at all.

Hi Sam,

Sorry, I didn’t notice this question until today. Are you still having trouble with this? If so, where exactly are you specifying the dependency on this .dll?

This tutorial helped me: I Don't Know UDK: Unreal Engine 4, Blender and Substance Designer Tutorials: How to Get Plugins to Package Correctly in Your UE4 Projects