Download

unable to rotate my character based on twin stick tutorial

i remember working on this back in 4.11 but right now in 4.14 is impossible for me to make it working, i’ve tried several type of rotations, mesh, actor, world, some working, but not as intended, i need help :frowning:

Show images of your nodes please. SetActorRotation should normally work. Did you check that the vector (of your cursor position) does have the correct value you want your characterto rotate to? Is your character mesh in the viewport of your character blueprint faced in the direction of the ArrowComponent? The mesh may need the rotation z(yaw)=-90.

How does which solution looks like and what is different from what you want to get?

as shown in here ca66db6e457ead7c48e93583fad784021d1647e5.png not working at all, i tried to change it for mesh, capsule component, and pretty much everything related to the character, it worked for the mesh, but not exactly how it should, because once you move the stick to a certain position, it starts to rotate uncontrollable

The vector length needs to be > 0.25. You have > 25 in case I see it correctly. The AxisValue of your InputAxis is in the range between 0 and 1 I guess. Where 1 means you’re pressing the stick completely to one side. I am wondering though why your character does even anything. I would expect that branch to be always false.

And you’re using SetActorRotation on the Controller. Not sure if that makes sense. It should be either SetControlRotation on your Controller or SetActorRotation on your character I guess.

indeed it was .25 before, but to make sure it wasn’t that i change it to 25, and in the input settings i put 25 too, but still didn’t worked, i also simulated this on a second screen and it is always true, i really don’t know what else to test it out, oh by the way i couldn’t find control rotation as shown in the video tutorial, that’s why many people was suggesting to work on character rotation :confused:

http://imgur.com/QidSjQW You can try this. It’s how I do it. Just assign what you need where you need it in inputs.

i’ll give it a try, thanks, ps: it worked but this is how i made it 7ae29e1480495eebb48d2ccaeb82faba829946ce.png although the dead zone if, isn’t working right now, it seems to bypass it as i tested now.

ps: working 100% :slight_smile:

Haven’t played with deadzones, but if it’s controller related I would try and use the actual controller software for it.

nvm it ended up working, i forgot to change the dead zone from project settings