Download

Unable to render from sequencer with media player track

Hi,

I’m trying to render a sequence with a media player track, basically just a video playing on a plane. On ‘Play’ everything works as intended but when i try to render a movie from the sequencer it basically ignores my CineCameraActor and renders from a random point in the level, not following the sequence.

I’m aware that media player and sequencer dont always get along. I’m playing both video and audio as media tracks, trying to render both to video and png sequence, added warm-up frames, etc. but nothing works, does anyone know any other option to try?

Hey there,

When I was trying this a few months ago I ran into a similar issue. I found a helpful BluePrint step in this vid (around 3 mins in):

https://youtu.be/7OEbO353_GM

Does that help?

-Eric

Unfortunately, no, the video is about playback in the viewport, in Game or Simulation. OP (and I) need to get the video playing in Sequencer.

Update: Never got to solve this problem. Ended up doing a screen recording, was the only way. If someone finds a solution please let us know.

i have excatly same problem mate .I’m searching to find solution about it like 10 or more days but nothing. I think there is only one way to render with this problem , i tried and its worked
render shots one by one as a png . Render all shots in same folder and bring them together with Adobe After Effect CC . This is only way for me for now .If you find extra solution please let me know to

I have the same problem.

I have a Composited track combining a CG background and a Green Screen feed from a Black Magic card. All I want to do is to record this out as a file. So I’ve dropped them into sequencer and found it has to be set to “Image Output Format - ComposureExport” in the Render Movie Settings to render both elements. No other formats work, AVI, Pro Res, all no good.

The problem I’m having now is that the BlackMagic feed (via a BMMedia asset) is frozen in the sequencer when I record. It works fine when I “Play”, but not when I record sequencer.

Any help would be appreciated. It’s a basic virtual studio setup I’m trying to do. My CG background is viewed through a camera linked to a Vive tracker via LiveLink.

I’ve since found FileMediaOutput in “Media” folder of the assets lists. I’ve added this to the Outputs section of my composited shot “0010_comp”, which seems like the better way to write the file. Thus avoiding sequencer. But for some reason this doesn’t write anything. :frowning:

Cracked it!

In order to save my “Comped” layers to file, I needed to add a FileMediaOutput to the output settings in my comp layer property details. In my case this object is called “0010_comp” - the default name when you make a new comp in Composure.

I then needed to make sure I opened the FileMeidaOutput asset and set all the parameters, even the greyed out ones. Previously the x and y parameters where already set and looked correct, but they were greyed out. Simply manually typing these back in seemed to do the trick.

I then noticed it worked when I “played” my project but… when I stopped the playback, it switches off the object in the Output settings. So the “Enabled” tick-box gets switched off. This makes sense unless you don’t know about it. So presumably I just need to script this to be enabled every time I Play my project, or just enable it manually each time.

My project now saves the composited image (blackmagic green screen feed + CGI scene) to file. Joy!

Now I just need to stop my vive tracker juddering and work out how to fix the lag between the blackmagic feed and the moving camera in my scene - controlled by LiveLink. Messing around with the LiveLink Buffer and Offset values, but this doesn’t seem to be very scientific.

They don’t make it easy… Hope this helps someone else. Any advice welcome…

1 Like