Unable to read/write to Play Leaderboard

My project will compile and run but I cannot get it to communicate with Play services. I’ve taken all steps I’ve found to be available so I can only assume this is a bug.

The steps I took:

  • Installed androidworks.

  • Filled out the SDK settings within my project.

  • Made a custom keystore and placed it under my [PROJECT]/Build/Android/ folder.

  • Added the following lines to [PROJECT]/Config/DefaultEngine.ini


  • Filled out Android settings:

    Under APKPackaging: Android Package Name, Store Version, Application Display Name, Display Version, Minimum SD, Target SDK.

    Under Distribution Signing: Key Store, Key Alias, Key Store Password, Key Password (all with what I used to make my key).

    Under Play Services: Checked Enable Play Support, Games App ID (just the numbers, didn’t include letter string), Play License Key, Achievement and Leaderboard Map after filling out information on Developer Console.

  • Built project as shipping.

  • Uploaded to Alpha testing on Developer Console.

  • Verified that the following API are enabled within the Developer Console: + API, Play Game Services and Play Game Management

  • Downloaded from Play Store.

I tried on 4.9 and again on 4.10 preview 3. I downloaded 4.10 using the launcher.

I’ve tested on Lollipop Moto X 2014 and an LG G2 on KitKat.

I absolutely do have a project you can take a look at. Would you prefer RAR or ZIP? It comes to about 18mb. I’ll be including the keystore passwords so what would be the best way to privately get you the archive?

You’re welcome to investigate my developer console as well, just let me know. As mentioned this problem has me stumped and I have honestly tried everything I could possibly think of.

Hey ,

  • Is this happening on more than one version of the engine?
  • Are you working out of 4.10 Preview 3 at this time?
  • Is it from Binary or GitHub?
  • What version of Android are you on currently?
  • Do you have a project that I too can look over?

I look forward to hearing back from you, thanks!

, I would like to write an updated and more thorough guide for users involving Play and leaderboard setup once I get this working.

I did have two questions that maybe you can answer:

A) Can you launch on mobile and have leaderboards work or must the APK be uploaded to the play store first? This is fairly important because there is roughly a four hour delay before you can access your projectper time you upload to the play store.

The Developer Console states (very conflicting information): “The following groups can test your saved drafts for Play game services before they are published.
You will also need to publish your android APK to Alpha Testing or Beta Testing.”

B) If you don’t need to upload your APK to test what is the bare minimum needed to test leaderboards and achievements?

Hey ,
I am currently having the same problems with my app and followed the same steps, but does your play service popup box apear onload? (The account selecter). Because mine does not even do that.

Jobvw, I do not get an account selection box either. Are you also on 4.10? Hoping can help me out and when successful I definitely don’t mind assisting you if needed. This thing has been a huge headache.

Yes I am also using 4.10 build 3, I am currently testing with a copy with a lower version. (4.9) I will update with more info if it works or not.

Sure, also check out this post: Integrate Google Play Services with Blueprint - Blueprint - Epic Developer Community Forums

The thread was literally created only a few days ago. I’m going over it now and will post with an update as well.

Well you have found the solution, I still need to make the highscore blueprints but I can login!

I was able to get the logon prompt but could not logon. It’s probably because I tampered with so many things trying to get this to work I broke something along the way.

Are you getting a On Success return for Show ExternalLogin UI, because I am not. Also, how are you testing? Launching to your phone or uploading to play store, or previewing as mobile?

I am just launching it on my phone, and yes it is triggering a on success return. It could be that your email account is not in the test list on the console.

The same set of number what I use as my games app id(12 digits).

Is Logged In returns False, so I then use Show ExternalLogin UI which prompts correctly, and I then get the permissions screen -App would like to access…-, but after that I receive an On Failure response. I’m running the game from my device as well.

Are you using the full Android ID (10-13 digits and a mix of alphanumeric) or just the numbers (10-13 digits long usually)?

Yeah, I’m not having much luck. I posted more information on Integrate Google Play Services with Blueprint - Blueprint - Epic Developer Community Forums in hopes another might see what I’m doing wrong.

Another unusual thing that’s happening is it takes ages to Launch the package to my phone. Previously only the initial launch took some time and following launches would be completed in under 20 seconds, down from the current 3-4 minutes. It’s almost like the project is being recompiled several times throughout the launch.

“LogPlayLevel: [crunch] Crunched 9 PNG files to update cache
LogPlayLevel: -package-resources:
LogPlayLevel: [aapt] Creating full resource package…
LogPlayLevel: -package:
LogPlayLevel: [apkbuilder] Current build type is different than previous build: forced apkbuilder run.”

Occurs with full rebuild on or off.

The account I tried to log into is under the testers list. I believe the Play Logon screen is crashing the app. The app restarts once I try to login.

Apparently this isn’t an uncommon issue. I’m thinking the problem isn’t on my end – and how you managed to get so lucky beats me. I’ll have to do some more poking around then probably post a new bug report. Haven’t heard from the Epic staff in awhile.

Hey ,

Did you upload the packaged project for me to test out? If you don’t want to share it publicly, go ahead and provide the link to me within a private message on the forums. Could you also include your off of your phone?

If there is any additional information that I need to know for your project that shouldn’t be shared publicly, include that in the PM as well.

Thanks. :slight_smile:

I resolved the issue. The project had to be built as shipping so that the key signature met the one I made, rather than the debug key.

This however: Google Services work but any UI elements crash game - Blueprint - Epic Developer Community Forums

has me stumped

Thank you . I’ll mark this question as resolved and move onto the next one for you. I have assigned myself to it.


very bad explanations, and jump for your problems only…