Unable to push scaled actor with modified mass

So I have a sphere that I can push around with my spectator pawn, pawn has radial force. When I make sphere larger, I can’t push it around, even after I lower mass scale to set mass same as old value. Still can’t push it, even if I make mass smaller than before. sad thing is, when I keep sphere same scale and adjust mass scale, it makes a difference. Also, if I push another smaller rigid body into sphere, it moves. Thanks in advance for any solutions.

Hi ,

Would you mind providing reproduction steps? I have thus far been unable to reproduce this effect. How did you set up your pawn class and how are you setting up your sphere? Thank you and have a great day!

How I’m setting up my pawn:

Open Class Viewer Window

Add Default Pawn Actor to my scene

Create Blueprint from Default Pawn, named CustomPawn

Add Radial Force to CustomPawn BP with 100,000 force.

Compile and Save Blueprint.

Edit > Project Settings > (GAME) Maps & Modes

Under Default Modes, create a new game mode named CustomGameMode

Under Selected Mode > Set Default Pawn Class to my CustomPawn.

How I setup my sphere:

I create a sphere geometry brush, create static mesh from brush using Brush Settings, right click on sphere actor in hierarchy and choose edit sphere, add collider (sphere simplified collision). Then I am able to tick “Simulate Physics”. This works fine, I can push around spheres and boxes, until I make them larger and mass increases. So I adjust Mass Scale under physics options for specific object I want to push around, so mass ends up being equal, or even less than smaller bodies alike. I can’t push them anymore with my player alone. In order for them to, I have to push another smaller rigidbody into them.

Update: If I make large object bouncy, I can push it no problem, and mass scale has intended effect. Also works if I give my player projectile movement. It seems like physics body isn’t affected by player controllers if it isn’t moving, or if player controller isn’t some type of physics body itself. Is there a way to give “kinematic” physics to player pawn, where as it won’t be affected by gravity, and won’t move through other objects? If not, could I just create a new class that uses a controllable physics body with a camera?

Ahh, scaling brush before hand makes sense, I’ll try that out for now as a workaround! Thanks for information :smiley:

Hey ,

I was able to reproduce issue you’re describing, and we’re looking into cause currently. For now, your best bet is to make brush size you want before creating your mesh, as problem seems to lie in how scaled objects react to physics.

Thanks for report and your update, and I’ll let you know as soon as we determine where bug lies.