Unable to package with steam plugin


I’ve updated my project to 4.15 and I’m unable to get the steam overlay working in 4.15. When I enable the steam plugin and try to compile, it prompts me to install visual studios. Which is strange because my project has no c++ in it and compiles in previous versions just fine and the steam overlay works.
If I install Visual Studios and try to compile with the steam plugin enabled it compiles for a few seconds then errors out. The only error line in the log file is “PackagingResults:Error: Error Unknown Error”.
Now if I disable the steam plugin it compiles just fine but the steam overlay doesn’t work. Also if I disable the steam plugin and have Visual Studios uninstalled it will still compile but the steam overlay doesn’t work.

Not sure what’s wrong here as I have no issues in previous versions.

I’ve also tried created a clean project using the templates and I’m getting the same compiling issue when enabling the steam plugin.

Hey Kitatsuki,

Try looking at the guide I linked below, and ensuring that you’ve followed all of the necessary steps to set up Steam in your project:

After doing that, if you still experience a packaging failure, please provide the full log from your project’s Saved->Logs folder after packaging.


Thank you for the quick response!

I’ve went through that document and am still having the same issues in 4.15, even with a new clean project. The only way I’m able to compile is by installing visual studios. The projects I’ve tried compiling aren’t C++ projects and I’ve never had to install it before in order to compile.

I’m attaching my log file as you requested. Hopefully this helps :smiley:

Thanks again!

link text

Thanks for providing the log. It looks like the issue isn’t with Visual Studio. It looks like you’ll need to install Windows SDK 8.1.

UnrealBuildTool: ERROR: Windows SDK v8.1 must be installed in order to build this target.

Give that a shot and let me know if that resolves the issue.

Thanks again for the response!

I’m still having the same issue after installing Windows SKD :frowning:

I’ve attached a newer log.

I’m not seeing the new log attached to your latest comment. Could you try to attach it again?

Oh ■■■■, sorry.link text

at line 214 i see this :
[2017.03.08-00.18.29:882][ 41]UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

Good find!
I went back to my Visual Studios install and had to manually add in all the C++ stuff and I’m able to compile now :smiley:


Great then!