Download

Unable to package the StrategyGame sample for Android (binary)

Greetings, i’m just testing the performance and compatibility of different devices using the samples provided in the launcher and i’m stuck at packaging the StrategyGame for android (any texture format). The problem is it asks for a .so file specific for strategygame :

ERROR: Can’t make an APK without the compiled .so [C:\USERS\specificuser\documents\StrategyGame\Binaries\Android\StrategyGame-armv7-es2.so]

Its not asking for UE4Game-x86-es2.so but rather the StrategyGame-armv7-es2.so;

Am i missing something? I’ve managed to package any other sample and even new projects slightly modified without doing any additional work. As i understand it the error should only appear when you try to package for android with x86 settings in the UE4 however since i don’t have the github version the options are grayed out for me but i can see the armv7 option selected rather than x86 so whats the deal?

Any help will be appreciated.

Problem solved after compiling with VS2013 then packaging with UE4 to android. Its probably a bug with the StrategyGame as all other projects packaged fine only with TADP installed.

Hi Xcalibur22,

It is my understanding that StrategyGame is the only of the mobile ready preview projects that was built in C++ and not blueprints, thus it requires VS2013 compiling. However, it should ( I think) compile automatically as part of the packaging process. I’ll see if I can reproduce on my end, and if it is a bug I will put in a JIRA issue for it. Thanks for the report!

So I tried this using the launcher/binary editor on 4.7.3, packaged for ETC1 and was unable to reproduce. It packaged and pushed to the device with no problems, so I am not sure what happened in your case, Xcalibur22. Does this happen every time you try and package?