Unable to package project; tried most things

Hi,
I’m in a bit of a tight situation here, with our month-long game jam due in two days, I’ve tried to get rid of the warnings from the output log in the past few days now but after experimentation it seems they aren’t the main reason that I can’t package my project.

Here’s my output log:
link text

Note on the things I tried:

  • I am able to package empty projects and other games with 4.7.6 and other engine versions
  • I have tried packaging with developmental/shipping, both giving the same results
  • I have tried moving folders
  • I have tried packaging with different engine versions
  • I have done everything with blueprints
  • I have tried using different computers to package; no difference
  • InternalUtils.SafeDeleteEmptyDirectory: WARNING: Failed to delete directory E:\Unreal Projects\MayGameJam2\Saved\Cooked\WindowsNoEditor\Engine\Content\EditorBlueprintResources in 10 attempts.\par … for all the similar lines with this, I have made sure these files exist and have no permission issues. I am unsure why it is saying permission denied.
  • I have tried migrating the map to an empty project; for some reason half of the objects in scene and a bunch of assets weren’t migrating properly (this doesn’t happen to other projects). All the instanced static meshes disappeared (which I used Rama’s plugin to instance), there were ~20 extra errors, twice as much warnings, yet the project packaged successfully. Thinking this might be the plugin’s job, from the original project I removed all traces of the plugins, removed all instances (making them individual meshes), yet there was no difference.
  • I am unsure if this has anything to do with it, but when the meshes were instanced, I could play them normally in the editor, but as a Standalone game, the meshes disappeared and I fell through the floors. It just seems the game doesn’t see instanced static meshes…but this could be an entirely separate problem from packaging.

As this is a pretty big project I don’t think I can go through each asset and blueprint to figure out what’s stopping packaging in 2 days. From the output log I can’t seem to figure out which warning is the crucial one to fix - hopefully someone can point me in the right direction.
Thank you!

Hello Michael,

I wanted to let you know that I have submitted your question to our developers to further investigate the logs that you’ve received. Do you have a back up of your file that you’ve been able to successfully package? Have you tried copying your project and converting the copy to 4.8.0 Preview 4 to see if that fixes the issues or not?

Looking forward to hearing back from you, thanks! :slight_smile:

Thank you for the reply!

Unfortunately I do not have a back up file. Since this was a Game Jam game, we did it mostly through one go, and it was our mistake for not testing packaging through-out the development time.

I will certainly try copying it to 4.8.0, but it will take me a few days to get a steady internet to download that. If anyone would like to help us and try it out, this is the link to our project: Google Drive: Sign-in

Hey Michael,

You’re very welcome. I did download your project and tried to convert it to 4.8. One of the plugins that you’re using isn’t optimized for 4.8 so I wanted to give you that heads up before you converted it over. Whoever created the plugins may need to adjust them for the upgrade in the engine.

I also was not able to package your project, it failed almost immediately. I have also went through UFE settings and tried to package your project, which failed after about ten minutes.

If you participate in a Game Jam again, I highly recommend that you save it in intervals of backups and test it for package and development along the way. It could be as simple as one of your plugins.

I notice in the logs that it says you need to have Visual Studio 2013 installed, do you have it installed on your computer, or the computer you’re packaging from?

Yes, I do have VS 2013 installed (on all the computers I tried packaging from). It’s weird that that showed up, since I’ve built everything with only blueprints.

I also tried removing the plugin and all the instanced static meshes that the plugin made, yet there was no difference.

Hey Michael,

When you removed the plugin, did the log errors change or did they look exactly the same? If you still have them, would you please provide the new logs to me?

Hi Samantha,

Thank you so much for the time you helped me, but since the GameJam has ended, I have decided to not pursue this any further. It does seem unrealistic but the GameJam hosts were nice to download and evaluate the game through UE4 editor. Hopefully a future build may fix this problem.
Again, I appreciate your help. Thank you!

Hey Michael,

You’re very welcome. If you have any further questions, please let us know. Remember, save back up files and check packaging often! :slight_smile:

Have a great day!