Unable to package project for device iOS

With a lot of help and patience from Jeff Lamarche I’ve tried just about everything I can think of, the errors I’m getting are that when I package a project for iOS the ipa file doesn’t show up in the IOS directory created, also no matter what the project be it a blank shell, or tappy chicken the ipa’s that are located in [Game_Dir]/Binaries/IOS are always the same size, 59.5mb if set for development and 88.5mb for shipping. Jeff has run a copy of a project of mine and has verified it was able to cook and be installed on a device on his computer, however I’m unable to do so on my mac.

The thread on the unreal engine forums has copies of logs when i launch a project to device and when I package for iOS, as per Jeff, no errors stand out.

The thread on the forums is here: Crash on launch? Failed to open descriptor file - Mobile - Epic Developer Community Forums

Hi forgets,

Can you tell me what version of the editor you’re using, and whether it’s source or binary? I see from the screenshots that you have provisioning set up, have you run through all the Mac to iOS documentation just to make sure? Have you ever been able to package for iOS previous to this?

Also, at this point is the problem that you’re seeing that the ipa you’ve packaged doesn’t show up in the correct directory or that that they don’t appear at all? Are you still getting the launch on crash you mentioned on the forums? In your logs I see about 10 failed checks for matching iOS provisioning profiles, if you’re still having problems getting launch on to work, it may be that the provisioning profile you’re using to build does not match the one on the device itself. You might also consider clearing out any of those others that you’re currently not using.

Further, your iOS package logs look like succeeds, but there’s an error down at the very bottom:

Http request failed - A server with
the specified hostname could not be

Can you package Tappy and post the package logs for that so we can see if it’s getting the same error?


Hi forgets,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.