Unable to package project for Android: Unknown Error

Hi, Please help. Its been three days now, I am trying to package my project for Android with no luck. Parsing my output log, I can see some errors like access denied, but I cannot seem to make any sense out of it.

I even created a totally blank project with just a floor and a couple of lights and tried to package it with the same failed results.

Please can anyone help!


UnrealBuildTool Exception: ERROR: C:\\android-ndk-r10d/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1
  • Have you tried running the Editor as an ?
  • Can I see your Android SDK Settings from the Engine? (Project Settings > Android SDK)
  • Are you able to package a blank project for Android?

Looking forward to hearing back from you, thanks!

Thank you for your reply.

It seems that I have manage to fix it.

I think that the problem was the “CodeWorks for Android 1R5”. After I uninstall everything that has to do with Android on my PC, I installed "CodeWorks for Android and run the editor as an Admin and everything works great!

Thanks again for your reply

You’re very welcome. Please let us know if you have any further questions!