Unable to Package, no Cook.txt

Hi everyone,

I have a project that won’t cook, and no Cook.txt file gets generated when it fails.
I’ve attached the UAT_log.txt file from the editor, but it doesn’t seem to have much useful information.

Other projects can package correctly, and I’m running version 4.7.4.
PIE works fine, and there are no errors that I can see in the editor.

So, after some trial and error, I’ve found I can cook via the command line (UE4Editor-Cmd.exe) if I remove the “-fileopenlog” switch from the command. Any ideas as to why this would occur? What does that switch do?

link text

Well, I don’t know why it’s happening, but it’s crashing trying to read the .uproject file. The crash doesn’t make a lot of sense, but since other projects are working, maybe try duplicating the file and renaming it back or something. Can you open the .uproject file in a text editor?


In a text editor is looks like this:

	"FileVersion": 3,
	"EngineAssociation": "4.7",
	"Category": "",
	"Description": "",
	"Modules": [
			"Name": "ThirdPersonDemo",
			"Type": "Runtime",
			"LoadingPhase": "Default"

Which is exactly the same as a project that does cook (except the name).

I created a copy of the uproject file, which also fails the same way.

Could this be somehow related to Perforce?

So, after some trial and error, I’ve found I can cook via the command line if I remove the “-fileopenlog” switch from the command. Any ideas as to why this would occur? What does that switch do?


The -fileopenlog generates a file that is used later in the packaging steps but it is optional so a cooking without it is fine.
In a command window can you run the command attrib on uproject file that doesn’t work and run it again on a uproject file that cooks successfully? Is there any difference between the outputs?

Hi JoJo_2nd, thanks for the info!
They all have the A attribute.
For some reason other projects are now failing to Cook as well, even a brand new project from a template.
I’m beginning to think its either a permissions issue (ie: no write access to where it’s trying to create the file), or my engine install is corrupt somehow.
Is going nuclear with a re-install my best option here?

I wouldn’t go that far just yet :wink: but a permissions issues sounds probable. First, try resetting the permissions on your project folder maybe? In particular, there should be a Build folder in your project directory that the cooker will be trying to access. If you can’t reset permissions for some reason you can try deleting any ‘FileOpenOrder’ folders in the Build directory. Second, if you’re running a source build I’d try cherry picking across the commit ( 32cb798fa321291e2b5b5b4063fbc1abe28c9f64 ) from the master branch, you’ll probably need to fetch it first I guess. Then recompile and see how it goes. Then as a last resort, a re-install may fix things…

Ok so I’ve tried some permissions stuff, the folders seem to always go back to “Partial” Read-Only, not too sure why, but it happens even when they’re empty.
I deleted the FileOpenOrder folder as well, no change.

I also got fed up and did a full reinstall of the editor (downloaded from the launcher), which still hasn’t fixed the issue.

Any other ideas? I’d like to avoid using source builds if possible.

Confirmed it’s a permissions issue.
If I run the editor directly (via UE4Editor.exe) with Admin privileges, I can Cook and Build correctly.
If I don’t elevate permissions, I still get the same problem (even if running the exe directly)
However, if I make UE4Editor.exe always run with Admin (via Compatibility settings), it won’t open via the Epic Games Launcher.

So I have a workaround, but there do seem to be some strange interactions with Windows 8 permissions/admin privileges.
I think this has only happened due to a recent Windows Update, as I was previously able to Cook/Build.

For anyone else with this issue (running Windows 8), try going into the UE4 install (ie: C:\Program Files\Epic Games\4.7\Engine\Binaries\Win64), right click on “UE4Editor.exe” and select Run as Administrator.
That should let you build/package normally.