Unable to package a WIP game

I was following an Unreal Engine tutorial “Twin Stick Tutorial” to create a MVP and slowly working on it. Anyways after having done this I decided that I would like to package the project and during the packaging in the output log. It mentioned this “Failed to find object ‘Object /Game/TopDownBP/TopDownOverview.TopDownOverview_C’” throughout but I have no clue what is going on and was wondering if you could help. Thanks.

Here is the full output log: Output Log

Hi Bladekyle,

Please try the following to resolve this issue:

  • In your project folder, delete the Config, Intermediate and Saved folders
  • If a Derived Data Cache folder exists in the project folder delete this as well
  • In the directory where the engine is installed, locate the Derived Data Cache folder and delete all contents (they will be rebuilt)

If this does not resolve your issue, please post the new output log.


It hasn’t seemed to have worked, I followed your advise, then inputted the input data again then I tried to package it and I got the same results.

New output log: New Output Log

After you deleted the Config, Intermediate, and Saved folders, what do you mean you input the data again?
-I’ll try to recreate the issue here; Are you just using the “Twin Stick Shooter” blueprint template from UE4.11? (Not upgraded from any earlier versions?)
-If you’ve made major updates or are using custom assets can you send a link to your project to me on the Forum?

After I deleted the Config, Intermediate and Saved folders, I then added in the inputs under ‘Project Settings’ and ‘Inputs’, in order for the game to be playable. As for the game I was watching a tutorial of the Unreal Engine’s YouTube channel.

Tutorial Playlist: Blueprint Twin Stick Shooter | v4.8 | Unreal Engine - YouTube

I created it on 4.11 and have not upgraded it.

Hi Bladekyle,

I opened your project and packaged to the desktop with no errors at all using these settings:

Please try these settings and let me know if you encounter any errors. Note: there was one warning about the name being too long for the long name path… this is not important.

Also, aiming doesn’t work as expected, but this is an issue with the blueprint/code specifically with character movement, etc.

I’m unsure why it isn’t working for me, I selected the same settings and tried to do the same by packaging it to the desktop. Yet again it didn’t work, I set it to package and checked on it 10 minutes later and the output log was at this “MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.26-20.06.57:955][ 0]LogUObjectGlobals:Warning: Failed to find object ‘Object /Game/TopDownBP/TopDownOverview.TopDownOverview_C’” I then thought it was probably because I wasn’t giving it enough time, so I waited for about an hour and a half but no luck, it was still packaging but there was nothing happening in the log since I had left it, could it perhaps be something else?

Newest Output Log: [Output Log][1]


One error/warning I keep seeing is:

Users/Kyle/Documents/Unreal Projects/WZCOTP/Content/Maps/ArenaMap', but the path contains illegal characters '.'

But I was unable to locate this your project. Make sure no folders have an “.” in the name in the entire package path name.

For example:

Documents/Dog.eat/Project/Package/Final.Package.Directory (would be wrong)

Documents/Dog_eat/Project/Package/Final_Package_Directory (would be right)

Thanks a lot for the advice, I have finally being able to package the project, I decided to wait for the release of 4.12 and then update the project and that worked!. So I would like to say thanks for the helpful advice and the time you put in to helping me correct this.