Unable to open the Launcher after download - Error 0xc000007b

I can’t find a solution to this problem, I’ve done some research about this and none of the solutions I found seem to work for me.

Here is my log: Log.txt

Hey InnerDreamHMH-

What were you doing when you got this error? Which version of the engine were you working in? Any information you can provide will help determine what’s going on and what the problem is.

Cheers

Doug Wilson

I got this error when I tried to launch the program.

I suppose it is the lastest version, the one that we get using the current installer.

This is the first time I install any version of Unreal Engine on this computer.

And I can’t even open the Launcher, I get the error the moment when I click the shortcut.

Are you able to open any other version of the engine? Also try closing the Launcher and reopening it, then try opening the editor again.

Check this link for more information on the error you’re receiving: Unreal Engine won't launch Error code (0xc000007b) - Installation & Setup - Unreal Engine Forums

Read over the information in the answer and follow the steps to help troubleshoot the problem. If you have any difficulties or questions then attach your report to this post and we’ll work with you to solve the problem.

Cheers

Doug Wilson

There seems to be a lot, A LOT, of “Missing Module” and “Import/Export Mismatch or Load Failure”.

link text

Hey InnerDreamHMH-

It does sound like there are a number of things happening. Have you tried unintalling and reinstalling the engine yet? I believe some files may have been corrupted at install or may have not installed at all. Preforming a fresh install might restore the files if that is the problem.

Cheers

Doug Wilson

Wow, dependency walker is indeed reporting a lot of issues in that log. It looks like the launcher is failing to load every dll in your system32 folder for some reason. At the moment I have no idea why that might happen but let’s hope Doug’s suggestion works (uninstall/reinstall). If it does not, perhaps you can provide a bit more info about which installer you are using. There are two ways that you can find this info: First, you can tell us the name of the installer msi you downloaded since it includes some build info. Ex: UnrealEngineInstaller-0.1.2-3456789.msi

Alternatively, you can tell us the version number you see in the lower left hand corner when running the installer:

16986-installerversion.png

I have already tried to unistall/reinstall multiple time and it doesn’t do anything.

This is the installer: http://puu.sh/bYBBY/2961b56327.png

Yes, I have tried it, I have also tried to repair/reinstall various MVCs (mainly 2010, 2012 and 2013) that solved the issue for others but it just doesn’t work with mine.

One issue with the DependencyWalker log you provided is that you are using the x86 version of DW. This is the reason you are seeing a bunch of [ E ] entries. Would you be able to post the log again using the x64 version of Dependency Walker. You can download it from here:

Download Dependency Walker 2.2 x64 from here: Link

Hi InnerDreamHMH,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please post the info 0xDEADBEEF requested above.

Thanks,

TJ