Unable to move pawn using class blueprint

Hi guys.

I am having a minor problem here and I am sure it is something simple. What I am trying to do is press a button in my class blueprint and have my object move. For testing purposes I created blueprint in my level blueprint and it works fine there but for some reason the exact same blueprint does not work when it is in my class blueprint. Here are pictures of both the level and class blueprint.alt text

It is because it is a pawn that you are not possessing. Try setting the auto possess by player to enabled or changing the class to actor. Should work suddenly.

That did not work. And to be clear, I am not looking to possess it, only to get it to move.

It is probably something very tiny that I am overlooking. Gotta love issues like this!

Solved. All I did was restart my computer. No idea why it was not working before still. It was set to actor with receive input enabled before but did not work but now it suddenly does. Weird.

Interesting. Well glad it worked.