Unable To Look Around via RMB in Viewport

This is the copy of my original post which I appearantly posted into wrong section.

I can’t seem to right click on view port and look around.
This wasn’t an issue before version 4.9.
Normally I should be able to right click and look around (in X,Y, Z axises) as in FPS - “noclip” fashion.
But instead, right clicking + moving mouse makes me move up and down (on Z axis) only.
I tried resetting “keyboard shortcuts” and “viewports” to defaults from preferences.
This solved the problem in first time but I have the same problem now again and resetting doesn’t seem to make a difference.

I found a related question here:

But there wasn’t an answer there either.

I am using Mac with magic mouse if that’s relevant.

EDIT: Also I deleted the whole software and re-installed it. It didn’t work either.
EDIT 2: Odd… Changing between levels in content browser, problem once again vanished…

EDIT 3: There it is again. I shut down my computer last night. Turned it on this morning and the same problem again. Cant’ rotate camera with right click.

EDIT 4: Also, I can’t use scale, rotate and translate actions with W, E, R keys. Even on different sections of the editor, W, A, S, D keys make my viewport camera move around instead of activating shortcuts.

Only logical explaination I can come up with this situation is that somehow I am changing my editor settings without aiming to do so…

EDIT 5: I tried engine version 4.8.3 to check out whether this has anything to do with the update. The problem continues with its’ existense.

Hello onuryurdupak,

This is currently a known and reported issue (UE18330) with Mac viewports not gaining focus in the application. Windows that were open on restart have focus, but is in the background for Mac. This prevents clicking inside the viewport. This information comes direction from the report itself.

A quick question so I can add your answer to the report. Are you running the binary version of 4.9 (Start up from Launcher), or a Source Build of the engine (GitHub)?

With that said, thank you for taking the time to report this issue and let us know if you have any further questions.

Thank you,

Andrew Hurley

Two follow-up questions: 1-) Is there a temporal workaround for this? If not, may I ask for advice about how to proceed (using the editor) until the issue is solved? 2-) Is there a way for me to track the progress of this issue; knowing about its’ current status, whether a fix is provided or not when I check? Also to answer your question: I am using the Epic Games Launcher as start up.

Hey onuryurdupak,

By temporal do you mean temporary? haha

This issue has been backlogged as it has not affected enough users to gain traction. It also has to do with how Macs function in regards to their own set up and functionality.

Clicking the window a second time should gain you focus on your viewport and the editor, but if you are not able to gain focus or click in the editor at all, be sure you have all other applications closed.

The bug number I provided is mostly for tracking purposes for myself to have a reference when searching through our internal system to find an update to the issue. When a fix is implemented it is pushed to the Release Notes of the associated fix version. You can find the full Release Notes for our official releases on our docs page, and you can find the remaining on the Forums in the Announcements and Releases section.

Thank you,

Andrew Hurley

Problem disappeared again, no idea why.

But i think you misunderstood, i am not having any problem clicking on viewport. What happens is that viewport camera acts as if LMB is always pressed. So when i do RMB+Drag, it instead acts as if i am using LMB+RMB+Drag.

Other applications dont behave like this , and i also tried with another mouse.

I got the same issue. :frowning:

^up
The problem was my Logitech G600 mouse drivers.

I’m also having the same Issue, as @onuryurdupak mentioned it seems like for some reason UE4 is treating two finger click on touchpad as LMB+RMB hence instead of rotating, it moves camera up, down, left or right.