Unable to login into launcher

A work around: If you administer your own firewall try opening the port 5222.

Thanks for answering my previous question.
To apply all these fixes, i need to run UE.
I UN-installed the UE and Launcher also.
I re downloaded Launcher and tried to login to do a fresh download.
But login windows hangs for hours but nothing happens.
its occurring since yesterday.
Kindly help me.

Hi TYRENS-Jonas,
Thanks for quick response.
I tried this fix but my hard luck. It didn’t work that way.
I am still waiting for some good solution from Unreal Engine Support staff as there are many users like me waiting for right solution.
Thanks once again

Hi NotSoCreative,

Thank you for the report. As you know, we are currently investigating a string of ‘Please Wait’ issues.

While we are looking into it, any info you could provide would be helpful. Please follow the steps here to generate your Debug Logs? Post them here, along with your Dxdiag (system specs).

Hi NotSoCreative,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above. Then post back here with the requested info.