Unable to launch the launcher... Error code SU-PQR1603

As the title says I am unable to launch the epic games launcher. All attempts to do so are met with error code SU-PQR1603

I have tried the solutions outlined on these sites:

Perhaps I did something wrong, or am missing something.I have attached the logs I think you need o help me determine the issue. If you require a different file or whatever let me know.
Thanks a bunch for your help! :slight_smile:




Yeah, that looks like a Pre-reqs failure. Often times related to C++ redistributable or DirectX installation issues.

Might want to try this:

Let us know if that helps or not.

Edit: This was NOT the answer for this particular person. I haven’t found anything that hasn’t already been tried, so the issue may be very rare or undocumented as to a fix.

LogBuildPatchServices:Error: Prerequisites executable failed with code 1603

LogBuildPatchServices:Error: EBuildPatchInstallError::PrerequisiteError PQR1603

Thanks for your reply!

Unfortunately this was one of the fixes I already tried. I did try again however just in case, but it still did not work (same error).

Time to reinstall your OS :slight_smile:

Yeah, those aren’t easy when the standard fixes don’t work.

This issue has not been resolved. Why was the status changed?

This issue has not been resolved, not sure why someone changed it. Someone please revoke the “resolved” tag (I don’t have the permissions on my own question?) so I can actually get it resolved…

This was NOT the answer for this particular person. I haven’t found anything that hasn’t already been tried, so the issue may be very rare or undocumented as to a fix.

I’m amazed just anyone can make it the correct answer. I was just as confused as you were.

Hopefully someone has personal knowledge that goes beyond anything documented, as I’ve never seem a pre-req check fail so badly. I’m starting to get semi-serious about reinstalling the OS at this point. There are SO many possibilities as to the source of the issue, it might sadly be worth it.

OS corruption? Virus? Some undocumented OS pre-req? For all I know you are running an outdated or not fully updated OS. Possibly not a legit install off bit torrent. I’m not saying you are, it is simply impossible to know anything from here, when the standard stuff doesn’t work. Maybe the stars didn’t align correctly, or the NSA installed a keylogger that messed it up. Who knows, right?

Applying execute package: PortalPrereqSetup, action: Install, path: C:\ProgramData\Package Cache{66C5838F-B854-4A55-89E6-A6138747A4DF}v1.0.0.0\LauncherPrereqSetup_x64.msi, arguments: ‘’

Error 0x80070643: Failed to install MSI package.

I mean, is there any possibility for more info from the MSI failed installation?

Try this and post the result:
msiexec /i “C:\MyPackage\Example.msi” /L*V “C:\log\example.log”

That will log ALL information + Verbose information. I mean, if anything might shed light, hopefully that would.


For launcher issues, please visit http://help.epicgames.com/. We have recently modified our process for handling Launcher issues in order to provide the best support. If you do not find the resolution to your issue on the help site, please use the Contact Us button on the side of the page to receive additional support.

However, please feel free to continue your discussion on this thread in the meantime.

Also, we mark topics resolved strictly for tracking purposes. This never means that the discussion cannot continue on a thread, nor does it prevent the thread from being re-opened with a comment.

Have a great day!

Ok, after doing some digging, I think the logs.zip you provided had the verbose logs we needed.

These are my findings:

Log section that matters:

Calling custom action CustomActionManaged!CustomActionManaged.CustomActions.InstallDirectX

Installing DirectX.

Exceeded DirectX install timeout.

Failed to install DirectX.

CustomAction CAInstallDirectX returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

Action ended 20:49:20: InstallFinalize. Return value 3.

“Return value 3.” means the action that failed should be directly above this line.

“CustomAction CAInstallDirectX returned actual error code 1603” Is the offending action from withing the MSI that has failed with error code 1603. 1603 is fairly generic, I believe, and just means it didn’t work.

Generic possible solutions from MS: MSI installation error 1603 - Windows Server | Microsoft Docs

I would lean towards the SYSTEM account not having permissions, but that’s a total guess.

“Installing DirectX.” ; “Exceeded DirectX install timeout.” ; “Failed to install DirectX.”

Clearly this ^ is the output log from DirectX installer within the Custom Action above. There might be something wrong with your DirectX installation. A missing reg key? Could be many things, sadly. Timeout is pretty odd to see, so there is likely some logic that is failing in the installer causing it to hang.

Sadly, I can’t find anything about troubleshooting timeout errors for DirectX installations.

All I could suggest is looking into permissions for these folders: C:\Windows\Installer; C:\Windows\Installer\MSI8308.tmp-\

I hope this helps.

Ok, this makes more sense now. Thanks for posting the extra information as to how to follow up. I’ve pretty much done all I can to point Penguin/Andrew in the right direction. If that doesn’t prove fruitful, I’m sure going through your process will be the best next step.

Ok that is good to know! I will check out the rest of krillin’s suggestions and head over to you guys if they (unfortunately) fail.

Seems a little weird to mark them resolved for tracking purposes tbh. From my experience on various other forums, doing so drastically reduces the amount of users (who can actually help, not those searching the same issue) from opening the thread. But thanks for reopening it :slight_smile:

I checked, the files you mentioned have the proper permissions.

I tried running the DirectX End Time user again. First it said I had a newer version installed, nothing more needed. Then a dialog opened telling me the installation failed, please repair. Attempting to repair gave another error, directing me to the directx.log
and dxerror.log files.

So here they are. Hopefully they can shed more light on this issue. :slight_smile:

EDIT: Looking over them, they say a lot of stuff does not exist (that’s about the extent of it I fully understand). Other than this EndTime user, and Windows updates, how am I supposed to install/reinstall DirectX (assuming that is how I would acquire the missing files)?

In the meantime, while you are investigating his suggestions and visiting the help page, I’m going to mark this topic as resolved. However, if you do find a resolution for your issue on the help site or through communication with one of the support staff over there, feel free to post that answer here so other users can make use of it in the future.

Thank you!

All of those missing cab files are likely just install things that don’t matter. My guess is it looks for all possibly available cab files, and installs them if they were packed with the installer. It’s sloppy, but nothing can be done about that.

This installer attempts to load a dll, which fails to load. That’s not good:

Failed API:		LoadLibrary()
Error:		(1114) - A dynamic link library (DLL) initialization routine failed.

It tries to continue on, but of course without all of the proper resources loaded, you get:

LoadDSetup32() failed. - in the function DirectXSetupGetEULAW

My guess is that is the function that is supposed to open the Installer window and bring up the EULA, which fails, as the necessary library inclusions failed, which are almost certainly core Windows libraries for handling processes and windows.

Failed API:		CloseHandle()
Error:		(6) - The handle is invalid.

^ The handle is referring to the process that is supposed to be running right now, namely the EULA/Installer process. It is blank, because it didn’t initialize, likely in the LoadDSetup32() function.

Basically, the installer process can’t load properly, which would explain the odd behavior. It is quite possible your OS has some major issues.

You could try running some basic repair commands from an Elevated cmd window.

sfc /scannow

^ Will check to make sure all core OS files are in tact and will replace them automatically, if necessary (may require a restart once complete). It never hurts to run that command.

Without the machine in front of me, all I can say is there are some deep issues going on, that likely go beyond DirectX alone.

I had this error code to. I have Visual Studio 2015 already installed and found that it does not come with the C++ compiler pre installed which is what Unreal engine uses. To fix this problem I opened Visual Studio, went to File > New > Project and in the pop up window I chose Visual C++. This shows the option to download the stuff for C++. After it was installed I had to restart my computer. After the restart, I fired up the Unreal Engine Launcher and tried the install again and it worked.