Unable to launch projects on Pixel 2 XL (Android device)

After following the Android quick start guide and accepting the SDK license I still can’t launch my project onto my Pixel 2 XL. It just doesn’t show up in the launch devices. I’ve enabled developer options on the Pixel, I’ve tried it with and without USB debugging enabled. I’ve tried adding it as an unlisted device through the device manager in the launch options in the project. When I connect the Pixel to my computer with USB debugging enabled it as an unspecified device in “Devices and Printers” but when I connect it without USB debugging it tells shows it as a Pixel 2 XL device.

Any help would be great, thanks.

Hey DuckyDan,

Here are a few questions for you.

  1. Did you install the android usb driver from the Android SDK manager?
  2. Have you specificially turned on USB Debugging (Debug mode when USB is connected) in the Developer Options?
  3. Does the device show up when you type “adb devices” into a command prompt?

Hey Velrin,

I’m having the same issue that DuckyDan mentioned and have tried the steps you mentioned. The only inconsistency I’m having with those steps is that I have to navigate to…

C:\Program Files (x86)\Android\android-sdk\platforms

…in order for the adb devices command to work in Command Prompt. I’m wondering if a PATH is messed up, but since I used the default installer options for the Android SDK I’m not sure why that would be the case.

Do you have any other ideas?

Thanks for the help!