Unable to Launch Epic Games Launcher

Greetings Community,

I have seen a few posts about this issue around the net but none of the solutions seem to work for me.

When I run the launcher, it begins a process but no UI or menu seems to load. Has anyone found a fix or cause for this? Unreal Engine has yes to be downloaded or installed.

Eager UE4 User

Hi magagnon01,

Make sure that you meet the recommended hardware specs and all of you graphics card driver is up to date.

  • OS: A x64-bit version of Windows 7, 8, 8.1, or Mac OS X 10.9.2 or later.

  • Hard Drive Space: ~1GB recommended for installing only the launcher. More hard drive space is required if you wish to download and install games, editors and projects, or content from the Marketplace.

  • Graphics Card: Any DX11 compatible card

  • Processor: Quad-Core Intel or AMD processor

Afterwards, if the issue is still happening; please post this as a new report on the Installation & Setup section of AnswerHub. Make sure to reference this post and what you have already tried.