Download

Unable to launch app on ios device for testing purpose

Windows 10, iPad pro (iOS 11.1) is connected via usb, wifi is off, certificate and provision is valid. I hit launch in the UE4 editor and click All_iOS_On_PCName and always get deployment failed unknown error.
I tried different Engine versions 4.15 / 4.17 / 4.18 and different projects. What can I do?

Here is a last part of the log:
LogPlayLevel: [DD] … Install is 40% complete at phase ‘VerifyingApplication’
LogPlayLevel: Install \ Update of “ue4ios418.ipa” failed with Unknown error 0xE8000067 in 8,76 seconds
LogPlayLevel: [DD]
LogPlayLevel: Exiting.
LogPlayLevel: Took 16,057887s to run DeploymentServer.exe, ExitCode=1
LogPlayLevel: ERROR: Command failed (Result:1): C:\Program Files\Epic Games\UE_4.18\Engine\Binaries\DotNET\IOS\DeploymentServer.exe Install -ipa “D:\projects\Unreal\ue4ios418\Binaries\IOS\ue4ios418.ipa” -device All_iOS_On_DARTHVADER -additionalcommandline "-SessionId=548683BE43B6AF54FB75759C6E6A84D7 -SessionOwner=“dimension3plus” -SessionName=“Launch On Devi
ce” ". See logfile for details: ‘DeploymentServer-2017.11.08-14.37.20.txt’
LogPlayLevel: (see C:\Users\dimension3plus\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.18\UAT_Log.txt for full exception trace)
LogPlayLevel: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 24.025519
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Deployment failed! Unknown Error

As a workaround I created an .ipa and drag+drop it in iTunes on my ipad, the icon appears (a wrong one) but when clicking it says “can not install” or something similar. So currently I don’t have a chance on testing my ios-apps before uploading them.

Please help.

Best regards
Olaf

I’ve been having this problem constantly. I have launched to iPad Pro, iOS11 from 4.17.2 before but since then and on 4.18 I’ve had the same problem, you’re not alone.

I have remade my certificates several times and I’m sure they’re fine like yourself.

Have you noticed if your Provisions are highlighted green in the project iOS settings? Mine haven’t been green for a while but are “valid” according to Unreal.

I’ve recently looked back through the Visual Studio 2017 installer and am wondering if there’s an option we’ve not installed? There is a Mobile option with C++ iOS support that I haven’t got installed by default.

The only other things I have heard is someone mentioned you need the project to be C++ only and Blueprints need to be converted to C++, but that’s from an old 2013 solution that nobody has verified.

Can you try making a new 3rd person mobile project and upload that? if that works then migrate your scene over and you’ll know if it’s anything in your scene causing it.

That or renounce the dark side and try calling your computer LUKESKYWALKER? :slight_smile:

Thanks CGough, glad to hear I’m not alone with that. Provisions are highlighted green with status valid. I just tried with a new project and dragged it on my iPhone 7, but it’s the same: the icon appears, it seems to be installed but pressing it only produces an error message. Renaming the computer isn’t an option either - it’s huge, black and glossy :slight_smile:

I’ve been following a few threads here and it seems a few of us are having the same issues with 4.18. I’ve not got any fixes yet but I’ve not had the time (or the iPad) to test anything today.