Unable to install marketplace content

I’ve recently been experiencing some issues with downloading and installing any marketplace content - I’m getting two different errors from the Epic Games Launcher when trying to either Add To Project or Create Project using marketplace content…

Error 1: Add To Project, when attempting to use Add To Project I get a “Install Failed; A file corruption has occurred. Please try again.”

Error 2: Create Project, when attempting to use Create Project I get a “Install Failed; A file access error has occurred. Please check your running processes.”

This error only recently began occurring while trying to install the DMX plugin, and now happens on all marketplace content on UE4.26, I have also tried installing the Valley of the Ancient sample project on UE5 and get the same error on that engine as well.

Actions I’ve attempted are to exit and restart Epic Games Launcher, disable anti virus and launched Epic Games Launcher, restarted the computer, reinstalled Epic Games Launcher, deleted vault cache to redownload content… All to no avail.

Update: I’ve also checked out the logs, I can see it running into error EBuildPatchInstallError::FileConstructionFail FC02-433,

[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: ErrorCode: FC02-433
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: FailureReasonText: A file corruption has occurred. Please try again.
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: FailureType: EBuildPatchInstallError::FileConstructionFail
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: NumInstallRetries: 4
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryFailureType 0: EBuildPatchInstallError::FileConstructionFail
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryErrorCodes 0: FC02-433
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryFailureType 1: EBuildPatchInstallError::FileConstructionFail
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryErrorCodes 1: FC02-433
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryFailureType 2: EBuildPatchInstallError::FileConstructionFail
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryErrorCodes 2: FC02-433
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryFailureType 3: EBuildPatchInstallError::FileConstructionFail
[2021.05.27-07.24.31:271][893]LogBuildPatchServices: Build Stat: RetryErrorCodes 3: FC02-433

I ended finding out the issue, the drive my Vault Cache was on is on its way to the bin - it’s got a bunch of bad sectors and is clearly in its death throes. Problem solved!