Download

Unable to install 4.8 Preview 1

Hi,

I have tried 4 times to download and install the preview, but I get an error each time: Install Failed - A file corruption has occurred. Please try again.

Any idea what might be causing this?

Thanks,

Hi Onoa,

What steps are you taking to install the editor? Do you have enough space on your harddrive to hold the new engine version?

Hi Adam,

I’m simply adding the engine version and press the install button. Once the download finishes and it processes the install, this is when the error occurs. There is plenty of space available on the drive. My install folder for the launcher is not on the C:\ drive. It is located on a different drive. Also, I have initially used a modified version of the launcher to install the launcher, because with the standard one, I am unable to install it in a folder with a path longer than 32 characters.

I used the install file from this post (I can’t use the new one since this issue is still not resolved with the new launcher). After the install, the launcher updates properly and I have never had any issue updating or adding engine version since last year, but I am mentioning it because the current issue might be related to the install path length maybe?

https://answers.unrealengine.com/questions/69220/i-cant-install-ue4.html

Thanks,

How long is the path name you are trying to use? Have you tried using one less than 32 characters to see if this is the error? If so it may be a problem with the modified launcher degrading as opposed to the engine having errors, which would be helpful in determining where the error is located so we can take a look.

The current existing installation path for the Launcher is 42 characters long. Btw, I’m not trying to do a fresh install right now, the error occur when trying to add a new engine version, using this pre-existing installation.

I will try to do a fresh install of the launcher and see how it goes. I will report back with the results.

Thanks,

After testing it, a fresh install solves the issue and I am able to download the 4.8 preview 1 version. After installing it, I have reverted to my old install setup in order to put everything back on my other drive using the modified launcher. However, it seems that this modified launcher is now unable to update and I receive the following error message:

LauncherUpdateError.jpg

Looks like I can’t revert to my previous folder structure anymore…

While looking into this matter, could it be possible for someone to look into the install path length issue as well and fix it in the new launcher (this issue has been opened for almost a year now)?

Also, another reason why I was sticking with the modified launcher is because the folder install name has changed at one point from Unreal Engine to Epic Games and it’s not possible to change it during the install. With source control setup, other PCs, etc, I just felt like it was not worth re-installing / redoing the setup on everything just because of the folder name change.

For this reason, I’d like to take this opportunity to request to make it possible to change the installation folder name during the install. After we select the install path, when it come back to the install path window, the Epic Games name could be added automatically to the path, but this path should be editable.

i.e.

61ceff94322153114b076b113df1f8ad4847f687.jpeg

Thanks,

Would you mind making a new post on the answerhub at http://answers.unrealengine.com in the installation and setup section and link that post here so we can assist you more in depth? Thank you!

Sure, there you go:

https://answers.unrealengine.com/questions/224457/unable-to-install-48-preview-1.html

Thanks!