Download

Unable to import CAD file

Hello all,

I request your help because i’m unable to import CAD files trough datasmith/import CAD. I tried on several computer and each time unreal (4.19.2) crash (i force it to stop with crtl alt supp after several minutes where it stay at 0%). I also tried several files, STEP, 3DM, solidworks without sucess. the best score i get is 60% in the import popup but it stay here more than an hour before i stop it.
I’m new to unreal, so i’m sure i miss something to get this function work. I checked if datasmith is activated. All my PC are in window 10 64bits.

I hope you can help me, i’m really looking for experimenting product design visualization with unreal.

Best regards,
Hugues

Ps: sorry for my english.

Hi there Hugues :slight_smile:

This is strange!
From what i understand you have downloaded and installed Datasmith already.

If you have installed Unreal for the first time and your Unreal Studio Subscription is active.
You should be good to go.

Since its not the case,
You may want to double check in your launcher.
Make sure your Unreal Studio subscription is set to Active.

b78431cc00016783b12cd1bc134eb92b8085506b.png

Also check in case the plugin needs to be updated:

6d8f10ed1ef9f6b44bc11835761bdee08e45691b.png

If everything else fails…

You could always try removing the plugin (in case it did not install correctly)

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“small”,“data-tempid”:“temp_140095_1528917623693_149”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

Install to engine again.
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“small”,“data-tempid”:“temp_140096_1528917637644_252”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

If that did not fix your problem, we will need to investigate more.
Let me know

cheers

MC

Hi!

Thanks for your reply, i’ve checked all points you ask and it don’t work better. I cannot update datasmith but there is a yellow triangle in the plugin page. It’s the 0.182 version, can it be the cause ?
Now i will try with 4.2 version to see if it solve my problem.

Sorry about That :frowning:
Yes, try 4.20 , hopefully that should fix it .

Let me know :wink:

Great it work with 4.2 !
after few test, unreal studio is amazing !

thanks !

Awesome !! :slight_smile:

Hi Marie Claude,

Maybe can you help me now with an other problem… now i’m not able to update my second computer to 4.2, the list stay on 4.19, do you have an idea ?

Major engine versions do not update to the next version. If you have 4.19 installed on that computer, it will remain 4.19. To install 4.20, you need to click the +] button to add a new engine slot. You can then install the 4.20 Preview to that slot.

Hi guys, anyone know why some fairly basic rhino scenes (.3dm files) get stuck on 0% when using import CAD?
Is there some known issues with certain scene configurations? I can’s see anything wrong with the scene.
Unreal version 4.20.2
Rhino 6 3dm
materials using layer
no textures, no plugins
no lights no cameras
importing geometry and materials only

Not sure. There are no issues logged against Rhino importer, but that doesn’t mean you haven’t found something. If you can use our confidential upload to provide the file, we’ll definitely take a look.

Report Unreal Studio bugs here: https://unrealstudiohelp.epicgames.com/s/article/How-do-I-report-a-bug

Hi, @kenpimentel I think I have found what is locking the import at 0%. I deleted objects in the scene that seemed to be triangulated geometry and not just nurb surfaces. I think the tesselation, and surface conversion methods are freaking out when dealing with those.

This is common for objects like trees, leaves, cushions and curtains etc. I’m wondering what is the best workflow for getting scenes or at least objects like this through the import process from rhino.
There is a demo scene for vray lighting here: https://docs.chaosgroup.com/display/VRAYRHINO/Exterior+Lighting+QuickStart
I couldn’t seem to be able to import the 3dm file through data smith.

Any info you can give me on importing a scene like this would be greatly appreciated, thanks.

The only way this will get looked at is if you submit a bug report and file. There isn’t another mechanism.

I have a problem with solidworks format import. The Unreal engine 4.22 does not let me do it. I have the 2019 version of Solikdworks. I have installed Datasmith and all plugins.
I hope you can help me.
Thanks a lot.

Montxo

Please report all the details of your issue, and provide the file for testing, at this link: https://unrealstudiohelp.epicgames.com/s/case-community-page

Thank you