Unable to hide/reveal actor in-game

I’m trying to reveal/hide an actor/emitter in-game, the player should be able to see the actor if certain stats fit the criteria.
So far I’m only able to hide/reveal the actor by using the ‘new hidden’ in ‘Set Actor Hidden In Game’, but it is not possible to do so at run-time.

So my question is this: is ‘Set Actor Hidden In Game’ something that is not possible to use at run-time? And if so, how may I implement the same effect without using ‘Set Actor Hidden In Game’.

Added screen shot with the set-up I’ve used

I’m aware that the bool is not attached in this pic, but it should be, but in the case of it being attached the intended result does not happen.

Sorry, I don’t really understand your question. Everything what you setup in Blueprint (except the construction script) is supposed to run ingame…?

I’m not following you concerning the construction script. (Not that well versed in the terminology… and a bit dense at times :stuck_out_tongue: )

But I’ll try to clarify the question a bit… the challenge for me so far is that, not plugging in the bool, just checking it on/off in the “Set Actor Hidden In Game” box, the actor is hidden or revealed. But plugging in the bool and changing the parameters “intelligence” and “wisdom” does not change the visibility of the actor.
So I’m wondering if “Set Actor Hidden In Game” is a run-time command or not, or is my bp set-up wrong in some way?

And since finding hidden actors is a major part of the game I’m trying to make, its a bit of a chasm on the path to completion.

SetActorHiddenInGame does indeed work while running, setting this to TRUE should indeed hide your referenced actor.

This works as expected:


For individual components, you have to use ‘setVisibility’ for some reason which can be in conflict with hiddenInGame.

Thank you… that helped.

For the use I intended, I needed to use the setVisibility, so back on track.

It’s a little bit strange, I know. :wink: