Unable to get positional audio working

So, to my understanding, achieving positional audio requires mono channeled sound, and attenuation/spatialization enabled in the sound cue settings. I’ve done this, yet the sound plays as if it’s stereo and I can hear it perfectly in both ears. I’ve checked every setting over and over again. I’ve enabled Oculus and Resonance Audio to see if those will work with the spatialization, but nope. And yes, I’ve set them to be the platform choice in the project settings. Getting very frustrated with this because it just won’t work. Project is in 4.20, for those who will ask.