Unable to generate project files on 4.19.1

I have a UE4 source build that is compiled and located in this folder:

I ran Engine\Binaries\UnrealVersionSelector.exe to register the directory as an Unreal Engine Directory.

I have an Unreal .uproject here: D:\Projects\Firewall\Branches\UE4.19.1

I’ve double clicked on the .uproject and selected the correct source code version. When I right click and generate project files this error occurs:

Running D:/Projects/UnrealDev/Branches/UE4.19.1/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="D:/Projects/Firewall/Branches/UE4.19.1/Firewall.uproject" -game -engine -progress -log=../../../Engine/Programs/UnrealVersionSelector/Saved/Logs/UnrealVersionSelector-2018.04.19-13.29.41.log
ERROR: UnrealBuildTool Exception: System.IO.DirectoryNotFoundException: Could not find a part of the path 'D:\Projects\UnrealDev\Branches\engine\programs\unrealversionselector\saved\logs\unrealversionselector-2018.04.19-13.29.41.log'.
         at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
         at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
         at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
         at UnrealBuildTool.UnrealBuildTool.GuardedMain(String[] Arguments) in D:\Projects\UnrealDev\Branches\UE4.19.1\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:line 623

It seems like the Unreal Build Tool is mangling paths.

Here is the mangled path: D:\Projects\UnrealDev\Branches\engine

It should be: D:\Projects\UnrealDev\Branches\UE4.19.1\Engine

How can I resolve this? I’ve tried deleting saved and intermediate folders as well.

I just deleted my entire Unreal Editor registry in regedit. It fixed this bug. Somehow the registry got corrupted.

Had similar problem. Created “Saved\Logs” directorie. Somehow solved my problem

1 Like